Really angry with ORM performance

Thread is closed for posting
2 posts, 0 answers
  1. Nelson
    Nelson avatar
    62 posts
    Member since:
    Apr 2011

    Posted 04 Oct 2012 Link to this post

    Hi there telerik, again..

    I´m very angry with yours ORM.

    I developed some time ago one silverlight application with telerik's ORM. Now that the application as "a lot of data" (3000 rows per table) I´m getting problems with data. My application can´t start , i´m getting error loading tables...something like "Loading operation failed for query...Remote server returned NOT FOUND".

    This problem disappears if I clean some rows (4000) on my database, doesn´t matter what table I clean..

    I think that ORM loads everything to memory..I can´t figure out...but this is serious...

    So, can you explain whats going on? How can solve this issue?

    Another thing...I can´t access to is another problem..

    Thanks in advance,

    Nelson Silva
  2. PetarP
    PetarP avatar
    754 posts

    Posted 09 Oct 2012 Link to this post

    Hi Nelson,

     We are not loading anything in-memory in advance. The volume of data should not be a real problem here and I am guessing its just hiding the real problem your application has. Unfortunately the "Remote server returned Not Found" is a too generic error that can hardly lead us to the actual problem. I will have to ask you to enable WCF tracing as this will give greater detail on the problem at hand. Once you do that please share the actual error with us.
    As for your second problem - we have tried accessing the online documentation from several different machines and everything worked out just fine. Can you please verify that you are still having issues? If you are can you also verify that there isn't any filter or firewall that might be blocking you from visiting that url?

    the Telerik team
    Follow @OpenAccessORM Twitter channel to be the first one to get the latest updates on new releases, tips and tricks and sneak peeks at our product labs!
Back to Top