Radchart Performance

2 posts, 0 answers
  1. AM
    AM avatar
    17 posts
    Member since:
    Mar 2010

    Posted 14 Feb 2011 Link to this post

    I'm using a candlestick chart and evrything works fine as long as the Y axis Auto range propoerty is set to TRUE.
    I want to manually restrict the Y-axis range and I type in the following code:

    candleStickChart.DefaultView.ChartArea.AxisY.AutoRange =

     

    false;
    candleStickChart.DefaultView.ChartArea.AxisY.AddRange(0,50000, 1);

    But this causes the page to freeze and the chart doesn't get created. I believe this is a performance issue and looked up the following page:
    http://www.telerik.com/help/silverlight/radchart-performance-tips-and-tricks.html

    and found this:

     

     

     

     

     

     

    Specify fixed axis range manually - if your data changes a lot, but you know the ranges over which it will vary, you can disable the Axis auto-range algorithm and specify the Axis range manually. This will probably lower the processing time a bit. 

    But in the contrary , the processing time is increasing when i do this.
    Am i missing something here?

     

     

     

     

     

     

     

     

     

     

     

  2. Vladimir Milev
    Admin
    Vladimir Milev avatar
    1061 posts

    Posted 17 Feb 2011 Link to this post

    Hi AM,

    The reason for this is that you are choosing a step of just 1. In this way the axis needs to create 50000 axis ticks. Even if RadChart created them I believe the chart would be pretty unusable and extremely busy. You might want to try using a step of 5000 instead. Try it like this:

    candleStickChart.DefaultView.ChartArea.AxisY.AddRange(0,50000, 5000);

    It will look better and will perform very fast.

    Greetings,
    Vladimir Milev
    the Telerik team
Back to Top