Problem with Double data type column in radgrid view

4 posts, 0 answers
  1. sreelakshmi T
    sreelakshmi T avatar
    13 posts
    Member since:
    May 2010

    Posted 06 Jan 2012 Link to this post

    Hi All,
    I Have a RadGridView in that i have a column with Double datatype.If i give a value tas 1,2 for this column it taking it as 12.
    I am validaing the values in cell validating event.

    Any idea why it is behaving like this ? For integer field it working properly.

    THanks in advance
  2. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 06 Jan 2012 Link to this post

    Hello,

     You should check what are the current language settings in your environment. 

    Kind regards,
    Didie
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. sreelakshmi T
    sreelakshmi T avatar
    13 posts
    Member since:
    May 2010

    Posted 06 Jan 2012 Link to this post

    Hi,

    what should be the the current language settings ?

    thanks in advance
  4. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 06 Jan 2012 Link to this post

    Hi,

    Depending on what the current culture is, different decimal separator is expected. 

    For example if the current culture is "en-US", then the decimal separator is ".", not ",". The "," is a currency group separator.

    Kind regards,
    Didie
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Back to Top