This is a migrated thread and some comments may be shown as answers.

Problem after updating to Q3 2012

2 Answers 64 Views
TreeListView
This is a migrated thread and some comments may be shown as answers.
AKROS
Top achievements
Rank 1
AKROS asked on 26 Nov 2012, 08:13 PM
Hello Telerik,

I just updated to the last Q3 2012 release and my application doesn't work anymore.
It seems that the problem happens during expanding the rows. This code worked just fine in the previous Q2 release:

private void DataLoaded()
{
    this.busyEmployeeIndicator.IsBusy = true;
    this.treeListView.DataLoaded -= this.treeListView_DataLoaded;
 
    this.Dispatcher.BeginInvoke((() =>
    {
        // Expand the tree
        this.ExpandHierarchy(this.treeListView.ItemsSource);
        // Scroll to current week
        this.ScrollToWeek(Week.Current);
        // Close the busy indicator
        this.busyEmployeeIndicator.IsBusy = false;
 
        //this.treeListView.UpdateLayout();
    }));
}


private void ExpandHierarchy(object source)
        {
            if (source is ICollection)
            {
                foreach (object item in (ICollection)source)
                {
                    // Expand all departments
                    if (item is Department)
                    {
                        this.treeListView.ExpandHierarchyItem(item);
                        this.ExpandHierarchy(((Department)item).Children.ToList());
                    }
                       else if ....
                }
            }
        }

Note that ExpandAllHierarchyItems (method of the TreeListView) worked as expected. I tried to use the latest internal build but it didn't help.

I hope you can give me a fix as soon as possible.
Greetings,

Nicolas

 

 

2 Answers, 1 is accepted

Sort by
0
Yoan
Telerik team
answered on 29 Nov 2012, 04:14 PM
Hi Nicolas,

 I have tested your scenario but I could not reproduce the problem. For your convenience, I have prepared a sample project that you can find attached. Can you please modify it in order to reproduce the issue and resend it back to me?

Thank you in advance!

Kind regards,
Yoan
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

0
AKROS
Top achievements
Rank 1
answered on 04 Dec 2012, 08:27 PM
Hello Yoan,

Thank you very much for your answer.
Your project works without any problem on my side!

Currently, I'm not able to reproduce this bug with a minimal amount of lines... (my project is pretty big).
Facts are that it was working with the previous version 2012.2 and upgrading to version 2012.3 broke something.

I'm pretty sure that it has something to do with ExpandHierarchy since using ExpandAllHierarchyItems fixes the problem (but it's not the behavior I would like...).

I tried on a Windows 7 with IE9 and Windows 8 with IE10.
Thanks and greetings,

Nicolas
Tags
TreeListView
Asked by
AKROS
Top achievements
Rank 1
Answers by
Yoan
Telerik team
AKROS
Top achievements
Rank 1
Share this question
or