[PreSales] DataGrid and Chart are not supported with windows 10 creators update

7 posts, 1 answers
  1. Prashant
    Prashant avatar
    3 posts
    Member since:
    May 2017

    Posted 09 May Link to this post

    Hi Team,

    I have downloaded a trial version of your controls for my UWP app in which I have used your DataGrid and Chart controls but it seems that there are some issues with the creators update of windows10. The DataGrid is showing a black screen while the chart series is not consistent. However, everything is working fine in normal windows 10 machine. Please refer to the attached snapshots for your reference.

    Any help would be greatly appreciated!!!

    Regards

  2. Nasko
    Admin
    Nasko avatar
    690 posts

    Posted 10 May Link to this post

    Hello Prashant,

    We are already aware of an issue caused by the Creators Update in the Chart control. However, I am glad to inform you that the issue has already been fixed. The fix is available with the latest official released version of the controls - R2 2017. If you are using an older version please, upgrade.

    However, if you are using the latest official version and the issue is still observed, please provide us a sample project that demonstrates it so, we could investigate it further.

    About the DataGrid control we have also tested it with the Creators Update and were not able to observe any unexpected behavior - it seems that everything is working as expected. It will be of great help for our investigation if you provide a sample that demonstrates the DataGrid issue as well. Without being able to observe both issues on our side we could not tell for sure what might be causing them and to provide you with a prompt solution.

    We are looking forward to hearing from you.

    Regards,
    Nasko
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Prashant
    Prashant avatar
    3 posts
    Member since:
    May 2017

    Posted 10 May Link to this post

    Hi Nasko,

    Thanks for your response. I will wait for your release. Meanwhile, I will be evaluating your controls and get back to you.

    Also, could you please tell me when your latest build will be released?

    Regards

  4. Answer
    Nasko
    Admin
    Nasko avatar
    690 posts

    Posted 11 May Link to this post

    Hi Prashant,

    The mentioned fix in my previous response for the Chart control you could test with the latest official release R2 2017. Take as much as time as you need to evaluate the controls - we will really appreciate your feedback.

    As for your questions concerning the release date. I could not provide you with an exact date, but it will be around the middle of June.

    We hope the provided information will be helpful for you.

    Regards,
    Nasko
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Prashant
    Prashant avatar
    3 posts
    Member since:
    May 2017

    Posted 12 May Link to this post

    Ok thanks
  6. Jon Mikel Inza
    Jon Mikel Inza avatar
    1 posts
    Member since:
    Oct 2009

    Posted 10 Sep Link to this post

    Hi,

    I am also using the DataGrid under Windows 10 Creators Update and I actually have some issues:

     - repeated lines but they disappear if I load a new page and I come back to the previous one ( the one containing the DataGrid)

     - new records not displayed. In this case too, if I leave the page and I load it back, everything is normal

     

    At the beginning I thought it was a coding error but after many checks, it does not look to be the case.

    Both bugs only happen when the DataGrid is empty and I add new records (sometimes not displayed....other times displayed twice).

    I am using the version 1.0.0.5 of Telerik.UI.for.UniversalWindowsPlatform, VS 2017 and W 10 x64 Pro 1703 EN.

     

    Is this bug known?

    Is there a workaround except reloading the page?

     

    Regards,

     

    Jon

  7. Nasko
    Admin
    Nasko avatar
    690 posts

    Posted 13 Sep Link to this post

    Hello Jon,

    We are not aware of the described by you issues and we were not able to reproduce it on our side. Could you please, try to create a sample project reproducing both issues and send it back to us? Without a sample project we could not tell for sure if the issues are caused by the DataGrid and Creators Update or there is something in the application's implementation that is causing them?

    We are looking forward to hearing from you.

    Regards,
    Nasko
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top