osascript prompt when enabling capture on Mac

2 posts, 0 answers
  1. Peter
    Peter avatar
    1 posts
    Member since:
    Sep 2017

    Posted 26 Sep 2017 Link to this post

    I installed Mono 4.2.4 (newer version of Mono didn't work at all) and installed Fiddler in a folder I have write access to.  I followed the instructions for syncing Fiddler and am able to successfully start Fiddler.  However, each time I click the File --> Capture link, I get the following pop-up:

    osascript wants to make changes.

    Touch ID or enter your password to allow this.

     

    I enter my password, and it is accepted, but still no traffic is captured.  When I click the capture link again, I get the same pop-up.

  2. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 28 Sep 2017 Link to this post

    Hi,

    Fiddler asks for credentials since it needs sudo permissions to change the machine proxy settings. It looks like in your case this logic does not work. Which macOS version are you using?

    As a workaround you can set Fiddler as proxy manually. To do that go to System Preferences -> Network -> Advanced -> Proxies and set the HTTP and HTTPS proxies to point to Fiddler. As a host enter 127.0.0.1 and for port you can check Fiddler's Help -> About. It is 8888 by default.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top