OpenAccess (Datacontrol) problems

Thread is closed for posting
2 posts, 0 answers
  1. Erik
    Erik avatar
    314 posts
    Member since:
    Feb 2008

    Posted 03 Dec 2010 Link to this post

    I’ve been at it all day, and yesterday evening…

    I just want a classes project with a model, and a application to consume the data via a datacontrol; the ORM OpenAccessDataControl. But every time I drop the datacontrol on the page, click the smart tag, choose configure, I get

    empty, please enable and compile project first

    I found this post:

    And I figured, well, let’s dive in. I’ve created about 50 projects, saw all video’s on ORM, followed this article:

    but no luck. Only thing i got working (after a while, version problems with VS2010) is this example in the code library:

    I do not see any differences between my project and the example, except mine is in VB. I thought it was maybe my MySql connection, or a VB problem, so I tried it in C# with the Northwind db. But no effect.

    I’m also a bit critical about the “getting started” and “easy do this, easy do that”. I have created a document during my travels last days, and you will see that is VERY time consuming. This could easily be  reduced by Telerik, I guess they don’t want that???

    All video’s, blog’s and examples are based on different versions of ORM. (1!) So, when I, as Zonan and Peter Brunner suggested in the forum post, try to “learn more of the basics” I get stuck because the video is clicking menu’s I do not have! Very sloppy work guys. When you make such big changes, you should update your getting started’s. If it was only from a selling point of view!

    I found that there are two ways of working: “domain model” and “Enable project”. Correct? I’ve tried both. (2!) This is new functionality and should be addressed in at least one of the video’s!

    An example:

    I create a new solution “sol1” with a project “TestData”, a Class library project. I right click the project, choose add item, select a “Telerik OpenAccess Domain Model”, click ok. The wizard is shown. I have to select a connection string. This is annoying: There are connect string in my app.config, but they don’t show here. Why?? (3!) When I recreate the connectstring and give it the same name, I’m ask to “update”. The wizard then deletes ALL connections and put only this one back! Whell… (4!)

    Moving one I select a name “AppModel” and select some tables. Then we are in the page where we can select some features. Nice, that’s Telerik (as I know them), thought of everything.. but… you have to enter it every time Signalize, pluralize, CamelCase… (5!) ok, the last page of the wizard: leave everthing default, behind ‘project’ I select browse, and messagebox is shown: "the item you have selected is invalid. Would you like to choose another?". Heu? (6!) This behavior is new in the latest version .1125, I’ve posted it already:

    Ok, leave it Blanc then… click Finish.

    Now I have a dll project with a model. Click “build”.

    Then I Add a new project to the solution, a webapplication. First thing: convert to Telerik RadControls project. Then add references to Telerik OpenAccess (3.5, 4, web). Add the connection string to the web.config. Create a new page (or change the default.aspx) add a radscriptmanager, a radgrid and a OpenAccessDataControl. Click “build solotion”. Go to design, click the “smart” tag, click “configure datasource”. Then there is a dialog popping up from VS2010: Save the following files? (7!) heu? I did not change anything and just saved everything. Does this Wizard do something? Say yes. And then…

    empty, please enable and compile project first

    nothing helps, recompile’s, save’s, nothing. I’ve seen this error at least 20 times now in different approaches, no solution. The example works, but I can’t figure out why, I do not see differences…

    As you can see, in my travels I find many problems, hope Telerik is gone do something about it, because I’m stuck and this 7 problem blog is no sales speech for Telerik ORM…



  2. Serge
    Serge avatar
    375 posts

    Posted 06 Dec 2010 Link to this post

    Hello Proovit,

     First of all I would like to apologize for the inconveniences we seem to have caused you. When using the OpenAccessDataSource you need to make sure that the project you are adding the control in has a reference to the class library and that you have recently build them. I have prepared a sample application that I have used for testing and all works fine.

    As to the forum post that Zoran and Peter responded to, you should note that it is from August last year, a lot has changed since. In the Q1 2010 version, we released the new Visual Designer that has become our primary target of development, since we have started referring to the old wizards as OpenAccess Classic and while they are still supported they are not further developed. 

    For the Q2 2010 release, we separated the menus for the two faces of OpenAccess and made the new one the default one. You can of course switch back to the Classic menu and have a look at this blog post on how to do that. This has brought some amount of confusion in the community but it was a step we had to take in order to more clearly map the future of the product. 

    I am sorry that for a new adopter such as yourself this has been confusing but we are and will continue to work on improving the experience for you. We have made an effort and have made explanations as clear as they could be in the installed help and the online help. In it you can find clearly defined help sections for both faces of the product. The general Getting Started refers to the Visual Designer and under OpenAccess Classic you can find all the old articles.

    We have yet to update the old video materials that have misled you and I apologize for that. 

    As to the connection strings in the Create Model Wizard, only the connections in the server explorer pop up, adding the ones from the config files might result in duplicates and this is why we have not yet implemented it. We will take it into consideration in the next planning meeting. 

    When our wizard is updating the connection strings, it does not delete all of them. However the formatting is lost in case the configuration file is opened while this operation is executed and they end up in one line. If that is not the case and they are really deleted please speak up so that we can further investigate the issue.

    The issue that you have posted in the other thread has been investigated, found and fixed, you should receive a confirmation there if you haven't already.

    Given the steps you have described I can see one missing, and this is adding a reference from the web project to the class library containing the model, also after doing so one should copy the connection string from the class library to the web.config of the web project. You have to have a reference to the project in order for the wizard to be able to find the context or scope that is used as an entry point to OpenAccess.

    I would also like to express my gratitude for taking the time to prepare and list the problems you have found. The feedback is highly appreciated and I assure you that it will help us to make OpenAccess a better and more usable product. 

    I hope this is helpful and please do not hesitate to let us know for any troubles you face or suggestions you have on improving OpenAccess.

    All the best,
    the Telerik team
    Accelerate your learning with industry's first Telerik OpenAccess ORM SDK. Download today.
Back to Top