This is a migrated thread and some comments may be shown as answers.

Nothing capturing on Mac 10.15.6

3 Answers 204 Views
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Richard
Top achievements
Rank 1
Richard asked on 26 Jul 2020, 12:54 PM

I've just downloaded Fiddler Everywhere for the first time and installed on my relatively virgin Mac. I am logged in as adminstrator, and have enabled capture of https, but despite visiting several unsecure and secure urls within my browser, nothing is being captured in the Live traffic capturing tab (which is enabled). 

 

When viewing the network proxies tab, nothing changes between when Fiddler is running and not running, both HTTP and HTTPS checkboxes are unchecked with no server details. 

 

Is there an additional step to configure that I am missing? 

3 Answers, 1 is accepted

Sort by
0
Nick Iliev
Telerik team
answered on 28 Jul 2020, 04:13 AM

Hi Richard,

 

By default, Fiddler is set to act as a system proxy and will capture the traffic that goes through that proxy settings. Check if your browser is using the system proxy or if it has some custom proxy settings.

 

Regards,
Nick Iliev
Progress Telerik

0
Richard
Top achievements
Rank 1
answered on 28 Jul 2020, 03:33 PM

Thanks for your reply. I was trying to use Fiddler to understand an issue in my rails app. I have tried the app and both Chrome and Firefox. Chrome is using the system proxy settings as is firefox. The rails app is just running on localhost with no special configuration. 

 

 

0
Garo
Telerik team
answered on 31 Jul 2020, 09:18 AM

Hello Richard,

Thank you for clarifying that you are testing on localhost. The functionality to capture requests to localhost is still being developed for the Fiddler Everywhere client. I cannot give you a precise time frame for when it will be available, but we hope to release it with version 1.1.0 of the client.

As a workaround, when you are making requests to the server, you can make them towards <machine name>:<some port> instead to localhost:<some port>. This way Fiddler Everywhere should be able to capture the traffic. Another option is to use one of these special aliases:

  • ipv4.fiddler
  • ipv6.fiddler

For example, if you are using IPv4, instead of typing http://localhost, you could directly input http://ipv4.fiddler.

Additionally, since we have moved the forums to a new home and you won't be able to reply here (the forums are now read-only), I would ask you to post in the new forum if you keep having issues with this.

Regards,
Garo
Progress Telerik

Asked by
Richard
Top achievements
Rank 1
Answers by
Nick Iliev
Telerik team
Richard
Top achievements
Rank 1
Garo
Telerik team
Share this question
or