Not loading results for script list run more than 60

4 posts, 0 answers
  1. Vimala
    Vimala avatar
    6 posts
    Member since:
    Oct 2018

    Posted 10 May Link to this post

    Hi,

         When i run test list more than 60 scripts in local machine it's not loading the results.May i get any suggestion for this please?

    Thanks & Regrads

    Vimala Padakanti.

  2. Plamen Mitrev
    Admin
    Plamen Mitrev avatar
    87 posts

    Posted 14 May Link to this post

    Hello Vimala Padakanti,

    The reason for this misbehavior is most likely caused by a System.OutOfMemoryException, when you try to open a large result file. Please check and let me know, if you experience the same issue, when trying to open results from a small test list execution.

    The OutOfMemory exceptions are related to how the Windows OS treats the installed applications and the memory they use from the available RAM. By default the 32-bit executable applications, like Test Studio, have an address space limitation of 2GB put upon the OS. So, even in the cases when the available RAM memory is much more, you can face such exception. 

    The solution, which you can apply for the computer you use to open the results, is listed as option 3 in this article along with some further details on the topic how Windows OS handles the applications' memory requests. Basically the idea is to turn on a flag which allows the 32-bit executable to use 3GB memory space block, instead of the default 2GB. 

    The flag in question is named "LARGEADDRESSAWARE" and should be turned on for few of the executable applications of Test Studio. The instructions advise to turn this on for the Telerik.TestStudio.Desktop.exe, and I will recommend you perform the same actions for the ArtOfTest.Runner.exe as well. In case your scenario requires scheduled test list executions, you need to turn on the same flag for the Telerik.TestStudio.Scheduling.Client.exe on that scheduling server and for the ArtOfTest.Runner.exe on all execution machines.

    Here are some additional points to help you turn on the flag on the required machines.
    • To be able to use the editbin command you need a Visual Studio command prompt started with admin privilege and C/C++ Build Tools component installed.
    • Then change the directory to the Test Studio installation one - C:\Program Files (x86)\Progress\Test Studio for default installation.
    • Execute editbin /LARGEADDRESSAWARE Telerik.TestStudio.Desktop.exe and then the same for the ArtOfTest.Runner.exe.
    • Then you can verify if the previous command was successful using dumpbin /headers Telerik.TestStudio.Desktop.exe. We are looking for "Application can handle large (>2GB) addresses" in the "FILE HEADER VALUES".

    Once you manage to turn the "LARGEADDRESSAWARE" flag, Test Studio will use 3GB from the memory and hopefully this will improve your experience with loading results from large tests. I would like to assure you, that our engineering team is constantly improving all aspects of the test execution and results in an effort to limit such issues.

    I hope that the above suggestion will help you resolve the encountered issue. Please do not hesitate to contact us again, if you need further assistance.

    Regards,
    Plamen Mitrev
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Vimala
    Vimala avatar
    6 posts
    Member since:
    Oct 2018

    Posted 14 May in reply to Plamen Mitrev Link to this post

    Hi,

        Thank you for the response.

    1.Actually we are testing new telerik test studio trail version.

    2.My system RAM - 4GB , 64- bit operating processor.

    3.We have gone through all the points mentioned in this link https://docs.telerik.com/teststudio/knowledge-base/getting-out-of-memory-exception-errors#option-3 provided by you . In my machine it's not showing those files -  editbin /LARGEADDRESSAWARE Telerik.TestStudio.Desktop.exe.

     

    Thanks & Regards

    Vimala Padakanti.

  4. Plamen Mitrev
    Admin
    Plamen Mitrev avatar
    87 posts

    Posted 15 May Link to this post

    Hello Vimala Padakanti,

    I would like to go back 1 step and analyze the application log, to see what is causing the misbehavior. I assumed that it is a System.OutOfMemoryException and my previous suggestion would help with that, but it might be something else. Please clear the application log, reproduce the issue and send the newly generated application log with your next reply.

    In the meantime I will try to understand what went wrong, when you tried to increase the memory for Telerik.TestStudio.Desktop.exe. In this case you have only 4GB of RAM and it get consumed quicker by Windows, Test Studio, browsers and other applications. Please check the suggestions below and let me know if they help with the misbehavior.
    • Our goal is to reserve more than 2GB of RAM to Test Studio and I would recommend to increase your RAM to at least 6GB.
    • Make sure that you have Visual Studio and you have started the Developer Command Prompt for Visual Studio as administrator.
    • Close all instances of Test Studio on the machine that you want to increase the memory. This should be the machine that opens the result files, because I assume they are actually causing the OutOfMemory exception.
    • Navigate to "C:\Program Files (x86)\Progress\Test Studio\Bin" and execute "editbin /LARGEADDRESSAWARE Telerik.TestStudio.Desktop.exe". In case you see any errors, please share a screenshot.
    • Verify the result with "dumpbin /headers Telerik.TestStudio.Desktop.exe" and check for "Application can handle large (>2GB) addresses" in the first several lines in the command prompt.

    I am looking forward to hearing from you and continue investigating the issue.

    Regards, Plamen Mitrev
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top