Need to click twice on GridViewSelectColumn to select all rows

6 posts, 0 answers
  1. Guillaume
    Guillaume avatar
    39 posts
    Member since:
    Nov 2010

    Posted 15 Sep 2011 Link to this post

    Hello,

    I have a minor issue in a RadGridView : when i want to select all rows by GridViewSelectColumn i have to click twice on the checkbox because the first click does nothing. Maybe a focus problem in the GridView. Can you help me ? Best regards, Guillaume
  2. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 17 Sep 2011 Link to this post

    Hi Guillaume,

     By setting the EditTriggers="CellClick" property of the GridViewSelectColumn the cells will enter edit mode with a single click only. As explained in this help article, the EditTriggers allows you to specify what action will set the cell in edit mode.

    Is this what are you looking for?

    Regards,
    Didie
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. Guillaume
    Guillaume avatar
    39 posts
    Member since:
    Nov 2010

    Posted 19 Sep 2011 Link to this post

    Hello,

    Thanks for your reply but i have not a "EditTriggers" property on GridViewSelectColumn.
    Then, when i load my data i set the "IsBusy" property on my GridView and when data is loaded i disable the "IsBusy" and it seems that the focus is on the first cell of the first row.
    So, i have to click once to set focus on the column and click once again to select all row (i click on the chckbox in the header of the column not in a row).
  4. Guillaume
    Guillaume avatar
    39 posts
    Member since:
    Nov 2010

    Posted 21 Sep 2011 Link to this post

    According to your reply in the bug ticket #466080 the problem is solved.
    Thanks for your time.

    Best regards,
    Guillaume.
  5. Ankur
    Ankur avatar
    1 posts
    Member since:
    Aug 2011

    Posted 07 Feb 2012 Link to this post

    I am dealing with the same issue. What resolved the problem for you?
    Or Telerik - what is the solution for not having to double click to select all items?
    ML-
  6. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 08 Feb 2012 Link to this post

    Hello,

     The reason for this behaviour was the lack of focus on the grid. 
    You should set the focus of the RadGridView when the data is loaded. You may set it like so: 

    private void ordersGrid_Loaded(object sender, RoutedEventArgs e)
            {
                (sender as RadGridView).Focus();
            }


    All the best,
    Didie
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
Back to Top