Missing Toolbox Items

4 posts, 0 answers
  1. Louis
    Louis avatar
    13 posts
    Member since:
    Aug 2011

    Posted 27 Nov 2011 Link to this post


    Does anyone know how to rectify the following problem?
    I had Q2 installed and all was well, I recently upgraded to Q3 and now
    I have no Telerik controls in my toolbox? I am sick and tired of battling to get 3rd party
    controls working properly. I think i have enough troubled finishing my software on time.

    I have tried the following:

    uninstall all telerik controls and re-install.
    Resetting the toolbox.

    Adding items manually is simply not good enough.

  2. Erjan Gavalji
    Erjan Gavalji avatar
    1455 posts

    Posted 28 Nov 2011 Link to this post

    Hi Louis,

    Sorry about that. Having the Toolbox not display third-party controls properly is most often related to the ToolboxControlsInstaller package (part of Visual Studio) not working correctly for some reason. This is one of the toughest problems to solve for a third-party vendor, for it's outside of our control. I want to assure you the Toolbox is a highest priority problem for us and we are hard working on having it fixed. Still it seems we aren't able to fix it for each usage case.

    Can you try the following steps? We identified them as a complete Toolbox reset and I hope they'll help you as well (please note, these involve modifying the registry and you should be extremely careful when performing them).

    1. Close all Visual Studio instances
    2. Run Regedit
    3. Navigate to the following key:
      HKEY_LOCAL_MACHINE\SOFTWARE\(Wow6432Node\)Microsoft\VisualStudio\10.0\ToolboxControlsInstaller. Please note, the path should not contain the Wow6432Node key on a 32-bit machine.
    4. Delete all the Telerik.Windows.Controls subkeys (if any exist)
    5. Navigate to the following key:
    6. Delete all the Telerik.Windows.Controls subkeys (if any exist)
    7. Navigate to the following key:
    8. Delete all the Telerik.Windows.Controls subkeys (if any exist)
    9. Navigate to the following key:
    10. Update the value of the Default Items value (increase it by 1, make sure it is greater than 0)
    11. Start a Windows Explorer instance.
    12. Navigate to the following folder:
    13. Delete all the *.tbd files (note, you would need to have the System and Hidden files visible to see the TBD files)
    14. Start the RadControls for Silverlight installer and choose Repair
    15. Wait for the installation to finish and start Visual Studio
    16. Create a new dummy Silverlight project and drag and drop a RadControls item from the toolbox.
    17. Close Visual Studio, load your project and try dragging and dropping a RadControls item to a page.

    Let me know if that helped.

    Kind regards,
    Erjan Gavalji
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. Paul
    Paul avatar
    1 posts
    Member since:
    Mar 2012

    Posted 10 Apr 2012 Link to this post

    The resolution worked for me, But I had to search for ToolboxControlsInstaller in the registry. The registry paths provided in the steps is not available under VS10.0
  4. Jonathan
    Jonathan avatar
    47 posts
    Member since:
    Sep 2010

    Posted 07 Aug 2012 Link to this post


    Thanks for this. It solved a similar problem I was having with missing Telerik AJAX toolbox items as well.

Back to Top