This is a migrated thread and some comments may be shown as answers.
Localization not working out of the box for the ScheduleView
19 Answers 143 Views
This is a migrated thread and some comments may be shown as answers.
samy
Top achievements
Rank 1
samy asked on 05 Oct 2011, 04:41 PM
From what i read on the forum, to localize your silverlight application in a different language, you just have to set the DefaultCulture property of the LocalizationManager before the InitializeComponent of your MainPage

public partial class MainPage : UserControl
   {
       public MainPage()
       {
           LocalizationManager.DefaultCulture = new CultureInfo("es"); // hablamos español
 
           InitializeComponent();
       }
   }

However, when i create a project from scratch with just one basic ScheduleView in the xaml, nothing is translated at all. Do i have to include resources satellite assemblies? If so, how do i include them in the correct resource directory (ie /bin/debug|Release/{culture}?
Currently, the bin directory contains lots of languages directories and assemblies (including Telerik.Windows.Controls.resources.dll)

19 Answers, 1 is accepted

Sort by
0
Yana
Telerik team
answered on 06 Oct 2011, 08:35 AM
Hi Samy,

You should edit the .csproj of your Silverlight application and add this line into the PropertyGroup section:

<SupportedCultures>en;es;</SupportedCultures>

Check here for more information about localization of RadScheduleView.

All the best,
Yana
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
samy
Top achievements
Rank 1
answered on 06 Oct 2011, 10:27 AM
Your link is empty. Could you point me in the right direction? However if it's the official demo, the code is not complete and nowhere does it say that you have to fill the SupportedCultures. Where can i find more info about this behavior. And if i want to change the default values provided, what's the way to go?
0
Yana
Telerik team
answered on 06 Oct 2011, 01:27 PM
Hi Samy,

I'm sorry for the wrong link. Please check it here.

We cannot show this setting in the online demos as it's in the .csproj file, but it's explained in the help article about localization (actually that is the link I've tried to send). Also it's a general Silverlight setting which is needed when using .resx files.

Please check Using Built-In Resources section of the article in order to localize the ScheduleView in Spanish.

Hope this helps. If you any additional questions, contact us again.

Greetings,
Yana
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
samy
Top achievements
Rank 1
answered on 07 Oct 2011, 03:17 PM
Thank you very much for the link.
I don't understand something, though: it says on the page you sent me to that "Spanish, German, Italian, Turkish, Dutch" is supported for the ScheduleView, but the demo example shows more languages, for example french. What mecanism is used in the demo?
What's more, you told me to edit my csproj to add my cultures to the SupportedCultures tag, but the documentation page tells me that this is for using the ResourceManager. I'd like to use the built-in resources, but jsut adding the recommended lines doesn't work

 
public App()
  {
      System.Threading.Thread.CurrentThread.CurrentCulture =
new System.Globalization.CultureInfo( "nl" );
      System.Threading.Thread.CurrentThread.CurrentUICulture =
new System.Globalization.CultureInfo( "nl" );
      
this.Startup += this.Application_Startup;
      
this.Exit += this.Application_Exit;
      
this.UnhandledException += this.Application_UnhandledException;
      InitializeComponent();
  }



0
Pooja
Top achievements
Rank 1
answered on 10 Oct 2011, 09:21 AM
Hi,
I am facing a similar problem, I have set Time format of my machine to HH:mm i.e. 24 hour format. But the calendar view still shows time ruler as 12:00 AM to 12 PM. Do we need to do any other settings for this?
0
Ivo
Telerik team
answered on 11 Oct 2011, 03:34 PM
Hi Samy,

Into the help article Yana sent you French is not mentioned, because the article is outdated. We will fix it.

In order to use the built in localization, you will have to edit your csproj to add cultures to the SupportedCultures tag. You can find working example attached.

Pooja,

TimeRulers are not affected by CurrentCulture of the application. You should bind the TimerulerMajorTickStringFormat property to the CurrentCulture.DateTimeFormat.ShortTimePattern of your application. You can also find an example attached.

Hope this helps.

Greetings,
Ivo
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Pooja
Top achievements
Rank 1
answered on 12 Oct 2011, 10:21 AM
Got it working by your suggested method.

Thanks!
0
samy
Top achievements
Rank 1
answered on 19 Oct 2011, 09:45 AM
The method is still not working with the supported cultures provided in the csproj.

I'm loading the Silverlight through an ascx hosted on a asp.net website. Should i check to see if the ressource assembly is missing (i guess everything is in Telerik.Windows.Controls.resources.dll in the fr folder)?

For your information, every Telerik assembly i've referenced from the Silverlight project lives in a "library" folder (to help with version numbering). What i have in this library folder is limited to what i use:
Telerik.Windows.Controls.dll
Telerik.Windows.Controls.GridView.dll
Telerik.Windows.Controls.Input.dll
Telerik.Windows.Controls.Navigation.dll
Telerik.Windows.Controls.ScheduleView.dll
Telerik.Windows.Data.dll
Telerik.Windows.Themes.Metro.dll

in the output folder for my silverlight project, i don't see the Telerik.Windows.Controls.resources.dll. Why doesn't it get generated?

0
samy
Top achievements
Rank 1
answered on 19 Oct 2011, 01:00 PM
I added the resource dll to my library folder in the correct culture folder and got it working this way. Thank you
0
Andreas
Top achievements
Rank 1
answered on 20 Jan 2012, 09:21 AM

Hello

I've notice that in the example project  "ScheduleViewLocalization.zip"  attached in a previous post 

the Day, Week, Month View is still not translated. I have the same issue. Although everything is translated

in the correct language they remain in English.

Thanks 

0
Ivo
Telerik team
answered on 20 Jan 2012, 10:25 AM
Hi Andreas,

This sounds really strange. I just downloaded the sample project and it was fully localized in French. Do you have the RadControls for Silverlight installed on your computer or you use only some of the dlls?

Regards,
Ivo
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Andreas
Top achievements
Rank 1
answered on 20 Jan 2012, 10:31 AM

Hello 

Thanks, for the quick reply. I have them installed on my computer.

This is what I get when i run the example project.

0
Ivo
Telerik team
answered on 23 Jan 2012, 08:46 AM
Hi Andreas,

I guess you copied your dlls from Telerik's installation folder to your project. You will have to copy the resoures folders (fr, tr, it, es, de, nl, sl) at the same place where are the Telerik's dlls you reference. You can see these folders at the image attached.

Kind regards,
Ivo
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Andreas
Top achievements
Rank 1
answered on 23 Jan 2012, 12:39 PM

Hello Ivo

I made some tests using other languages beside French. I've tried with Dutch, Deutsch and Greek. This issue appears also in Greek as shown in the attached picture. If I was missing any translation resource files the name of each day wouldn't remain in English too?

Thanks

0
Ivo
Telerik team
answered on 23 Jan 2012, 03:39 PM
Hi Andreas,

RadScheduleView doesn't support Greek langugage at this moment. I guess you use old version of Telerik RadControls for Silverlight that doesn't support French language too. Could you please check if your version is Q2 2011 or above?

Greetings,
Ivo
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Andreas
Top achievements
Rank 1
answered on 26 Jan 2012, 08:21 AM

Hello,

Yes my version is Q1 2011. Can you please send me a sample project, how to  translate ScheduleView  manually?

Thanks

0
Ivo
Telerik team
answered on 31 Jan 2012, 10:13 AM
Hi,

It seems there was a bug into the localization manager into the 2011 Q1 release and you won't be able to translate RadScheduleView manually. However you can find attached a resource dll that will translate everything in French. You have to place the "fr" folder into your binaries folder, as shown into the picture attached.

Kind regards,
Ivo
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Andreas
Top achievements
Rank 1
answered on 31 Jan 2012, 11:02 AM

Hello,

I would appreciate if you could send me a hot fix/minor release for the 2011 Q1 since RadScheduleView needs to be translated in other languages too.

Thanks

0
Ivo
Telerik team
answered on 02 Feb 2012, 09:09 AM
Hi,

I think the best option into your case is to upgrade your controls to the latest official release, because we do not offer and support custom hotfixes. Currently the last official release is 2011 Q3 SP1.

All the best,
Ivo
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Asked by
samy
Top achievements
Rank 1
Answers by
Yana
Telerik team
samy
Top achievements
Rank 1
Pooja
Top achievements
Rank 1
Ivo
Telerik team
Andreas
Top achievements
Rank 1
Share this question
or