Live traffic capture does not work for me

2 Answers 1212 Views
This question is locked. New answers and comments are not allowed.
Boogier
Top achievements
Rank 1
Boogier asked on 15 May 2020, 07:58 AM
Live traffic capture does not work for me
Eric R | Senior Technical Support Engineer
Telerik team
commented on 15 May 2020, 06:34 PM

Hi Boogier,

Thank you for the screenshot. In order to investigate this can you provide the following information?

1. What OS is Fiddler Everywhere running on?

2. Can you share a screenshot of OS Proxy Settings?

3. Is any 3rd party security or VPN software in use?

4. Can you share screenshots of the HTTPS, Connections and Gateway Tabs in the Fiddler Everywhere Configuration Settings as shown below screenshot.

5. In the bottom right corner of the Fiddler, there is a connection status. Does it say connected or disconnected? See the below screenshot for a visual reference.

Once I have the above information I will be able to investigate this in more detail. 

Please let me know if you need any additional information. Thank you for being a Fiddler Everywhere Insider.

Regards,


Eric R | Senior Technical Support Engineer
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
David
Top achievements
Rank 1
commented on 02 Jun 2020, 01:02 PM

Not working for me either.

Here is the information that was requested for somebody else.

Running MacOS Catalina 10.15.5

OS Proxy Settings are attached.

3rd Party security software, yes - Traps Endpoint Management.

VPN - yes, Cisco Anyconnect client.

HTTPS, Connections and Gateways tabs screen shots are attached.

Boogier
Top achievements
Rank 1
commented on 03 Jun 2020, 10:24 AM

Hi Eric

1. Microsoft Windows [Version 10.0.18363.836]

2. Proxy settings attached

3. No

4. Attached

5. Attached

When I enable Live Traffic capture I get ERR_EMPTY_RESPONSE in web browsers

Jason
Top achievements
Rank 1
commented on 10 Jul 2020, 03:12 AM

Hi Eric,

Seems like the new Fiddler do not caputure anything, not only browser and also postman, etc.

1. Windows 10 Pro [Version 2004] [OS Build 19041.329]
2. It always revert back to auto, I tried mannually change it back to `http=127.0.0.1:8866;https=127.0.0.1:8866`, but not working and it will change back to auto 
3. No
4. Attached
5. Attached

In my case, network seems still working but nothing is captured.

Old Fiddler can still capture properly without extra setting.

Nick Iliev
Telerik team
commented on 14 Jul 2020, 06:17 AM

Hello Jason,

 

Can you let us know if you are behind a corporate network or using a 3rd party security tool? it looks like that your proxy settings are reverted to auto which is preventing FE to set the proxy settings. 

You could also send us the Fiddler logs which on Windows should be located in

C:\Users\<USERNAME-HERE>\AppData\Roaming\Fiddler Everywhere\Logs

 

Regards,
Nick Iliev
Progress Telerik

2 Answers, 1 is accepted

Sort by
0
Eric R | Senior Technical Support Engineer
Telerik team
answered on 02 Jun 2020, 01:18 PM

Hi David,

Thank you for providing the screenshots. Our testing has uncovered a known issue when using Fiddler Everywhere with an active VPN connection on macOS. Can you disconnect the VPN and let me know if that works?

Additionally, as a token of gratitude for your feedback on this, I have increased the priority of the public Bug Report Item by casting a vote on your behalf. I encourage following it to receive future updates as well.

Please let me know if you need any additional information. Thank you.

Regards,


Eric R | Senior Technical Support Engineer
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
David
Top achievements
Rank 1
commented on 02 Jun 2020, 01:28 PM

Unfortunately I cannot disable the VPN. The Mac I'm using was provided by my employer and the VPN is always on and I don't have the ability to disable it.

I'll try Fiddler Everywhere on my personal Mac at home and see if it works there.

Thanks

0
Eric R | Senior Technical Support Engineer
Telerik team
answered on 03 Jun 2020, 02:15 PM

Hi Boogier,

Thank you for providing the screenshots. After starting Fiddler Everywhere, the proxy settings should look like the following screenshot. I believe something is blocking Fiddler Everywhere from configuring the Proxy.

As a workaround you should be able to modify the Proxy Settings Manually using the below configuration. Is this possible or do you get any errors?

http=127.0.0.1:8866;https=127.0.0.1:8866

Please give the above a try and let me know if you have any additional issues. Thank you for using Fiddler Everywhere.

Regards,


Eric R | Senior Technical Support Engineer
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
Asked by
Boogier
Top achievements
Rank 1
Answers by
Eric R | Senior Technical Support Engineer
Telerik team
Share this question
or