Issues executing scripts of WebAii v1.1 on Windows-7 (IE8 browser)

5 posts, 0 answers
  1. Sheetal
    Sheetal avatar
    8 posts
    Member since:
    Oct 2012

    Posted 26 Jan 2011 Link to this post

    Hi Team,

    I am using WebAii Test v1.1 to execute the scripts on Windows-7 IE8 browser.

    Q1. Is WebAii v1.1. supported on Windows-7?
    Q2. I found that the scripts were throwing exceptions when i tried to execute them in IE8 browser of Windows7(64 bit) for this I had to do some settings like,
    - Turn the 'Protected Mode' off.
    - Check the option "Disable toolbars and extensions when InPrivate Browsing starts" from Inprivate under Privac settings of Internet Options

    After performing the above options the scripts atleast initiated to open the browser and navigate the URL. However now we observed that the scripts are not able to perform any "Click" action.

    Can anyone please let us know the reason for these observations and failures.

    Regards,
    Devender
  2. Sheetal
    Sheetal avatar
    8 posts
    Member since:
    Oct 2012

    Posted 27 Jan 2011 Link to this post

    Hi Team,

    Please provide us feedback on this ASAP, since its high priority for us.

    Regards,
    Devender
  3. Cody
    Admin
    Cody avatar
    3354 posts

    Posted 30 Jan 2011 Link to this post

    Hello Devender Sharma,

    I am sorry for the delay responding to you.

    1) Yes, WebAii 2.0 runs just fine under 64-bit Windows 7. It doesn't support 64-bit IE, but you probably aren't trying to use that version of IE anyway. The 32-bit version of IE is the default on all versions of Windows.

    2) There is no reason we can think of why clicks would not work your configuration. We use that configuration quite regularly as do many of our other customers. Our developers use that very environment as well.

    What error do you get? Can you share with us the exception message and stack trace, assuming you are getting one?

    Kind regards,
    Cody
    the Telerik team
    Interested in Agile Testing? Check out Telerik TV for a recording of Automated Testing in the Agile Environment
  4. Sheetal
    Sheetal avatar
    8 posts
    Member since:
    Oct 2012

    Posted 30 Jan 2011 Link to this post

    Hi Cody,

    Our question was regarding the previous version of Webaii i.e. v1.1 and not 2.0.

    Can you please provide us information about webAii v1.1?

    Regards,
    Devender
  5. Cody
    Admin
    Cody avatar
    3354 posts

    Posted 31 Jan 2011 Link to this post

    Hi Devender Sharma,

    My most humblest apologies to you! I did misread your post.

    We would much prefer to work on getting your existing scripts working with our current code base then to try to support a code base that is about a year old now. The current code base contains many bug fixes compared to 1.1 and too many new features to list here. The biggies include Silverlight testing, running tests in Google Chrome and a lot of others.

    Please provide as much detail about the problems you are experiencing when you upgrade to our latest version so we can begin to work on these. We'd really like to see what we can do to ease the process of upgrading from older versions so that customers just like you have a painless upgrade experience. A few samples of your problem tests might help us better understand what you're running in to.

    All the best,
    Cody
    the Telerik team
    Interested in Agile Testing? Check out Telerik TV for a recording of Automated Testing in the Agile Environment
Back to Top