This is a migrated thread and some comments may be shown as answers.

How to remove selector column on left

6 Answers 533 Views
GridView
This is a migrated thread and some comments may be shown as answers.
Terry
Top achievements
Rank 1
Terry asked on 26 Nov 2009, 05:48 AM
I just want to show a very basic grid.  By default there are two narrow columns on the left in addition to the columns I define.  How do I remove them?  I thought CanUserSelect might work, but it didn't

Thanks,

Terry

6 Answers, 1 is accepted

Sort by
0
Milan
Telerik team
answered on 26 Nov 2009, 07:01 AM
Hi Terry,

The first column is our indicator column and the second one is actually the frozen column splitter. You can hide both by setting RowIndicatorVisibility to "Collapsed" and CanUserFreezeColumns to "False".

Regards,
Milan
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Terry
Top achievements
Rank 1
answered on 26 Nov 2009, 03:34 PM
I'm still seeing a column to the left.  Here's my XAML:

        <telerikGridView:RadGridView x:Name="tgvHospitals"   
             ShowGroupPanel="False" CanUserSelect="False" IsReadOnly="True" 
             RowIndicatorVisibility="Collapsed" CanUserFreezeColumns ="False">  
 
0
Vlad
Telerik team
answered on 27 Nov 2009, 08:26 AM
Hi Terry,

I've attached an example project using our latest binaries.

Best wishes,
Vlad
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
meir
Top achievements
Rank 1
answered on 28 Nov 2017, 08:27 PM

Hi Terry, I hope you've already solved the problem till now, but here is what I found in my application.

Thanks for your question as it helped me hide the first column.

About the column that you still see, this may be representing something, like in my case when I add items to the grid, this column will contain a '+' symbol to expand the details of the item.

Thanks again!

Mayer,

0
Prasanth
Top achievements
Rank 1
answered on 19 Feb 2018, 05:34 PM

Hi Terry, 

I came across the same situation in my Application. Here is solution I found. 

Set the attribute AllowRowResize to False for the Radgrid in Client settings.. 
<ClientSettings ........>
            <Resizing AllowRowResize="False"............. ></Resizing>
</ClientSettings>

0
Abid
Top achievements
Rank 1
answered on 19 Feb 2018, 05:37 PM
Thanks Prasanth, Your suggestions worked for me too.
Tags
GridView
Asked by
Terry
Top achievements
Rank 1
Answers by
Milan
Telerik team
Terry
Top achievements
Rank 1
Vlad
Telerik team
meir
Top achievements
Rank 1
Prasanth
Top achievements
Rank 1
Abid
Top achievements
Rank 1
Share this question
or