Gridview export to ExcelMl filter issue

3 posts, 0 answers
  1. Jack
    Jack avatar
    14 posts
    Member since:
    Sep 2011

    Posted 08 Nov 2011 Link to this post

    Hi, I am having a problem with using the export functionality in telerik gridview. I would really appreciate it if anyone could offer any help.

    When I call :

    grid.ToExcelML(true, true) //the parameters don't really matter

    an <autofilter> tag is automatically tagged to the end of the string output. Is there anyway to disable this?

    Because if there is an empty grid, the autofilter would cause a problem when opening the file in excel.

    How would I fix this?

    Thanks
    Jack
  2. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 09 Nov 2011 Link to this post

    Hi Jack,

     This option can be removed if you set ShowColumnHeaders to false for the export options. If your case is different you can export the grid manually by looping grid items and columns similar to this demo

    All the best,
    Vlad
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. Jack
    Jack avatar
    14 posts
    Member since:
    Sep 2011

    Posted 11 Nov 2011 Link to this post

    Hey Vlad,

    Thank you very much!! I solved my issue!
Back to Top