This is a migrated thread and some comments may be shown as answers.

Getting 400 Bad Request for unknown reasons

2 Answers 272 Views
Fiddler Classic
This is a migrated thread and some comments may be shown as answers.
Neil
Top achievements
Rank 1
Neil asked on 11 Feb 2015, 09:47 PM
I have been using Fiddler on my PC while sending traffic to it from my phone (Android 4.4.4). I can see all non-SSL and SSL traffic from our website within Fiddler, with no issues.
When I load our mobile app, however (which is partly-native and partly a wrapper for some parts of our mobile site), many (most) non-SSL pages are causing 400's (only through Fiddler). 

Fiddler Log show these type of errors when it happens:
15:36:11:3018 [Fiddler] No HTTPS request was received from (chrome:6192) new client socket, port 58271.

In the raw requests for these it shows a simple GET to our website http://www.foo.com/ but the pages I am trying to visit are not the homepage, so I am not sure how it's munging up the requests. The actual homepage is http://m.foo.com/m/e/digital/index.jsp and those are loading fine.

Auto-Responder is disabled and I am doing no other re-writing that I can see, with the requests.
I have been able to reproduce this on multiple networks.
I cannot recreate the issue in other proxy tools.

Let me know if there is any more information I can provide which may help me get assistance

2 Answers, 1 is accepted

Sort by
0
Eric Lawrence
Telerik team
answered on 12 Feb 2015, 04:22 PM
Hi, Neil--

Can you send me a SAZ file (Help > Send Feedback) showing the problem?

Are any of the pages in question HTTPS?

The LOG messages you're showing me here are from Chrome on your PC, not related to any requests from your phone.

How specifically did you configure your phone to send traffic to Fiddler? Is your phone tethered to your PC in some way? If so, are you using Desktop Chrome's Developer tools?

Regards,
Eric Lawrence
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
Neil
Top achievements
Rank 1
answered on 12 Feb 2015, 09:51 PM
I am not tethering in any way.  I am not yet loading SSL pages in the case of this issue.
I am on the same wi-fi network with both my laptop and phone.  My phone's (Android 4.4.4) wi-fi proxy is set to my laptop's IP and port which I specified in Fiddler.  Chrome Developer tools are not open, I am simply loading things on my phone through the browser or app, and then inspecting the requests/responses in Fiddler.  I tried Charles and cannot reproduce this same result.

It's a bit tricky to explain but essentially we are simply loading www.foo.com and then I click on a link that should load www.foo.com/dealoftheday (for example) and it shows a GET to www.foo.com with a 400 response.  This is after two successfull 200 requests that are our actual homepage.   There are obviously many other objects being loaded with each of these pages but for sake of this post this is essentially whats happening.

So you want me to email the .saz file to fiddler@telerik.com (as opposed to attaching here)?










Tags
Fiddler Classic
Asked by
Neil
Top achievements
Rank 1
Answers by
Eric Lawrence
Telerik team
Neil
Top achievements
Rank 1
Share this question
or