First time run troubles VS2k8-SP1 & MS-Expression Blend 3

2 posts, 0 answers
  1. Waleed Seada
    Waleed Seada avatar
    241 posts
    Member since:
    May 2006

    Posted 12 Jan 2010 Link to this post

    Dear All,

    This is my first ride through silverlight components, it's really new to me.
    I face a few problems at the beginning, thanks to the forum posts I was able to resolve some, some still ...

    In VS2008 I lost my designer after installing SL-3 but I found it hiding under the thin splitter of the xaml code view, anyway I am telling this because it might be the reason of my real issue.

    I start to work in MS-Blend3 and I build a small application were I try to use the RadDock as follows:
    <Grid x:Name="LayoutRoot" Background="White">  
        <telerikDocking:RadDocking Margin="8" x:Name="mainDock">  
            <telerikDocking:RadSplitContainer x:Name="spliter1" InitialPosition="DockedRight">  
                <telerikDocking:RadPaneGroup x:Name="pane1">  
                    <telerikDocking:RadPane x:Name="pane11" Header="One"></telerikDocking:RadPane> 
                    <telerikDocking:RadPane x:Name="pane12" Header="Two" ></telerikDocking:RadPane> 
    In MS-Blend3 it is not possible to add the radPane into radPaneGroup using Intellisense simply it is not there, so I decide to go back to VS2k8 and do this. VS2k8 Intellisense worked and I manage to add the radPane to radPaneGroup BUT with silly error appears when you hove over the end tag of the first radpane saying "AG_E_UNkNOWENERROR[line:20 position:83]", I still can build & run the project but I wonder why it is error happens.

    Next, I try to go back to MS-Blend3 and open my project, I found errors as INVALID XAML with red rectangle around and the result tab shows :
    (*) Cannot add content to object of type radpanegroup
    (*) The member Header is not recognized or not accessible

    Is there any integrity issue with MS-Blend3 ?

    How can I resolve these issues.

    Best to all
  2. Paul Wade
    Paul Wade avatar
    8 posts
    Member since:
    Oct 2008

    Posted 13 Jan 2010 Link to this post

    Hi Waleed,

    Silverlight 3 intentionally removed designer support for VS2008 as it wasnt ready. Use blend or write it by hand. I recomend blend and it seems youve already started that.

    I havn't run into many issues with blend 3, and it seems vs doesnt like the structure either... You seem to have matched the example from telerik, I can only suggest rebuilding the project.

    I have run into issues where blend picks up bizare errors untill I rebuild in blend, I dont think that is the case here and it may be a bug with the telerik controls.

    I havn't tried to replicate it in vs though. Could also be your enviroment I suppose. Sorry I know this isnt really any help
Back to Top