Filtering OpenAccessDataSource

Thread is closed for posting
3 posts, 0 answers
  1. Markus
    Markus avatar
    36 posts
    Member since:
    Dec 2008

    Posted 12 Mar 2009 Link to this post


    Till yesterday, I was using ORM 2008.Q3.1205. Now I'm using 2008.Q3.1421

    I have a RadGrid and bind it to a OpenAccessDataSource. Initally The Where property of the DataSource is "1=2". After the user enters some criteria, the Where property is set to the appropriate filter, e.g.
    "textTyp.tTId = 2 AND (tABez LIKE '%tel%' OR tAId = 106 OR tAId = 110 OR tAId = 147)"
    After that, I rebind() the grid. And the desired datas showed up in the grid.

    This worked fine till yesterday before i updated OpenAccess.
    Now, I always get all the datas, the inital load with "1=2" and every other filtering does nothing. It looks like the Where is now totally ignored.

    Are there any changes in the behaviour of the DataSource I have missed? Or is there something else I'm doing wrong?

  2. PetarP
    PetarP avatar
    754 posts

    Posted 13 Mar 2009 Link to this post

    Hi Markus Ruf,
    we tried to reproduce your case locally and everything works as expected. We are using the new Q1 2009 release. Can you please update your OpenAccess with the newest version and check if everything works for you too. If the problem is still there we advice you to create a simple application representing the problem and send it to us in order to solve your problem.

    All the best,
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Markus
    Markus avatar
    36 posts
    Member since:
    Dec 2008

    Posted 16 Mar 2009 Link to this post

    Hi PetarP

    Thanks for your answer. I didn't help much, but I was able to correct the behavior.

    The problem was the use of the OpenAccessDataSource as DataSourceID for the RadGrid.
    It worked with Q3.1205, but not further on.
    I removed now the OpenAccessDataSource and bound the RadGrid to a DataSource (not to a DataSourceID). That fixed the problem. Now, filtering works like before.

Back to Top