Fiddler + Proxifier error

11 posts, 0 answers
  1. Zdzichu
    Zdzichu avatar
    1 posts
    Member since:
    Feb 2019

    Posted 21 Feb Link to this post

    Hi guys, i trying to connect fiddler and proxifier, in proxifier i add address 127.0.0.1 https on port 8888, but it not work good

    have a look 

  2. Alexander
    Admin
    Alexander avatar
    383 posts

    Posted 26 Feb Link to this post

    Hello,

    What are using Proxifier for in this case? From the screenshot it seems that you are trying to debug Chrome traffic. Is that correct?

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Nijaz
    Nijaz avatar
    10 posts
    Member since:
    Mar 2019

    Posted 18 Mar Link to this post

    I am using Proxifier and Fiddler without problems. It depends on settings of Proxifier. In my case I am not handling direct connections, few allowerd apps use proxy localhost to connect with your-freedom vpn app. You do not have to make any rules in proxifier for fiddler. It does not support https over http proxy, or http over https proxy unlike system does. Show screenshhots of settings, rules, servers.
  4. Nijaz
    Nijaz avatar
    10 posts
    Member since:
    Mar 2019

    Posted 18 Mar Link to this post

    I am using Proxifier and Fiddler without problems. It depends on settings of Proxifier. In my case I am not handling direct connections, few allowerd apps use proxy localhost to connect with your-freedom vpn app. You do not have to make any rules in proxifier for fiddler. It does not support https over http proxy, or http over https proxy unlike system does. Show screenshhots of settings, rules, servers.
  5. Triple
    Triple avatar
    5 posts
    Member since:
    Mar 2019

    Posted 19 Mar Link to this post

    Me too need help with that, please. Thanks!
  6. Triple
    Triple avatar
    5 posts
    Member since:
    Mar 2019

    Posted 19 Mar in reply to Triple Link to this post

    My settings in proxifixer rules:
  7. Nijaz
    Nijaz avatar
    10 posts
    Member since:
    Mar 2019

    Posted 20 Mar Link to this post

    Well depends on what you want to do. What are your default internet proxy settings. How do you live? What is that new rule for?

    Which apps you wan to do what? What were the settings before using Fiddler? Trick is to avoid proxying anything to Fiddler or Charles through Proxifier, but do it in Internet Options. For example in internet options proxy all apps through Fiddler, and only proxy fiddler through direct connection by making rule for it. Simple. Proxifier has problems with http and https proxying localhost for debugging network programs. But not with socks5 proxy which is how am I using it.

  8. Triple
    Triple avatar
    5 posts
    Member since:
    Mar 2019

    Posted 23 Mar in reply to Nijaz Link to this post

    Can we please contact somewhere? I can pay you about 10$ if u can help me, thanks!
  9. Triple
    Triple avatar
    5 posts
    Member since:
    Mar 2019

    Posted 23 Mar in reply to Nijaz Link to this post

    Look, I have a program and I want to see traffic of that, but I don’t see it by the simple method through the settings in Windows, and if I turn on the proxifixer and start the program, I see that packets go, but there are errors in my debugger charles / fiddler ( I do not see the contents of the packages) I need to see what is stored in these packages, really need help with that
  10. Nijaz
    Nijaz avatar
    10 posts
    Member since:
    Mar 2019

    Posted 23 Mar in reply to Triple Link to this post

    Contact me at nijazmuratovic@yandex.com. Just tell what program, and show screenshot of current proxifier settings and current lan proxy used in internet options in control panel.

  11. Nijaz
    Nijaz avatar
    10 posts
    Member since:
    Mar 2019

    Posted 25 Mar Link to this post

    To answer here too why it does not work. I was able to recreate the same problem (error number).

    Mistake visible in screenshot in proxifier is that fiddler was forced to go over fiddler via proxifier, because even tough it is told to go directly and that rule is properly prioritized in Proxifier, Fiddler already made its rules like it does always, in internet proxy settings. So there were double rules. Proxifier+Fiddler work perfectly for me: https://postimg.cc/fVPTdfBH

Back to Top