fiddler not work with TLS 1.2 site (https://38.is-mis.ru/pp/) on win xp sp3

2 posts, 0 answers
  1. gjhgkyunygukngu
    gjhgkyunygukngu avatar
    1 posts
    Member since:
    May 2018

    Posted 14 May Link to this post

    hi respect for fiddler, i am from russia

    subj, yes win xp base not support tls 1.2, only third party libraries supoport tls 1.2 on win xp (curl, openssl)

     

    log from fiddler

    HTTP/1.1 200 Connection Established
    FiddlerGateway: Direct
    StartTime: 07:57:56.679
    Connection: close

    fiddler.network.https> HTTPS handshake to 38.is-mis.ru (for #47) failed. System.IO.IOException Неожиданный EOF или 0 байт из транспортного потока.


  2. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 15 May Link to this post

    Hi,

    As you said - Windows XP does not support TLS 1.2. Since Fiddler highly depends on Windows APIs, it does not support TLS 1.2 either.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top