fiddler can't capture any traffic

8 posts, 0 answers
  1. yuan
    yuan avatar
    1 posts
    Member since:
    May 2017

    Posted 06 May 2017 Link to this post

    fiddler can't capture any network traffic. There is only one session captured that it's a update test session about fiddler itself.

     

    my os is Win10 latest(1703),  can anybody help me?

  2. Chuck
    Chuck avatar
    2 posts
    Member since:
    May 2017

    Posted 12 May 2017 in reply to yuan Link to this post

    I am having the same issues with Fiddler.  I am also on Windows 10 Version 1703 and Fiddler version 4.6.20171.14978.

    Everytime I attempt to capture traffic, I receive an error "Failed to register Fiddler as the system proxy.  

    Tried to change browser that Fiddler is using but don't seem to find how to do this.  Fiddler appears to be using I.E. browser connection which is not working within Fiddler.  However, if I just run I.E. within Windows, it works fine.  Possibly this is the cause of the above error.  

    Can someone help?

  3. Tsviatko Yovtchev
    Admin
    Tsviatko Yovtchev avatar
    549 posts

    Posted 16 May 2017 Link to this post

    Hello,

    Could you guys check out your proxy settings after Fiddler started? Does it start working if you manually change these to 127.0.0.1:8888?

    Regards,
    Tsviatko Yovtchev
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  4. Chuck
    Chuck avatar
    2 posts
    Member since:
    May 2017

    Posted 16 May 2017 Link to this post

    Tested this same version of Fiddler in Windows 8.1 and it is working great.  Something in Windows 10 Version 1703 is making it unusable.  

    Tsviatko, I am unsure as to what you are asking?  I did enter 127.0.0.1:8888 in the Chrome address bar and received a good 200 response code.  However, everytime I attempt to capture traffic, I still receive an error "Failed to register Fiddler as the system proxy". 

    What else can I try to get this to work in Windows 10 Pro x64? 

    Thank you.

  5. tempo
    tempo avatar
    2 posts
    Member since:
    May 2017

    Posted 18 May 2017 Link to this post

    same here since 2 days ago start to give me this error and wont open anything. havent install, unistall or made changes in my computer, i used to run swf files in games and now is down i try everything unistall fiddler, installed again, used old version, new version, i try different make cert that the program provide i did reset cert, clean history unistall chrome and installed again. and nothing. only works in firefox (dont like firefox), but in chrome and coowon dont works. any ideas or maybe it need a new certificate that doesnt said fiddler , i dont know lol. i ran out of ideas or procedures
  6. Tsviatko Yovtchev
    Admin
    Tsviatko Yovtchev avatar
    549 posts

    Posted 22 May 2017 Link to this post

    I mean your Network&Internet -> Proxy setting. Fiddler is trying to point that to itself, i.e. 127.0.0.1:8888. If Fiddler fails I wonder what is in the settings and what would happen if you manually change them to 127.0.0.1:8888

    Regards,
    Tsviatko Yovtchev
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  7. tempo
    tempo avatar
    2 posts
    Member since:
    May 2017

    Posted 27 May 2017 in reply to Tsviatko Yovtchev Link to this post

    fixed the error in webpage when fiddler is active but now autoresponder file dont work is not sending the data to the page or something dont know what else to do. 
  8. Eitan
    Eitan avatar
    5 posts
    Member since:
    Sep 2015

    Posted 29 Sep 2018 Link to this post

    The solution for the Fiddler error of "Failed to register Fiddler as the system proxy" is in the following link, but you have to reboot after applying it to make is active.

    http://www.rudyhuyn.com/blog/2018/01/10/how-to-fix-fiddler-when-it-cant-set-the-proxy-on-windows-10/


    A copy of the text, if the link will vanish one day:

    "

    Type Windows+R and enter services.msc is the textbox.

    Then look for WinHTTP Web Proxy Auto-Discovery Service, right click and select Properties.

    Change the startup type to Automatic and then click on Start.

    If for any reason you can’t change the startup type cause disabled, open regedit, go to HKLM\SYSTEM\CurrentControlSet\services\WinHttpAutoProxySvc and change start value to 2.

    "
Back to Top