Error when adding datepicker for RC0

2 posts, 0 answers
  1. rh
    rh avatar
    192 posts
    Member since:
    Jan 2007

    Posted 01 Oct 2008 Link to this post

    When I add the datepicker I get the error below. I'm using the RC0 bits from MS and from telerik.

    Could not load type 'Telerik.Windows.Controls.SelectionMode' from assembly 'Telerik.Windows.Controls, Version=2008.2.826.0, Culture=neutral,PublicKeyToken=9c7324f9b8e4111a'

    I previously had the Beta 2 telerik bits referenced in this project, but removed the reference, actually deleted all of the telerik controls form my xaml files, and referenced the RC0 telerik bits. Not sure if there is an old reference or something sticking around, though.

    I tried the RadTimePicker to code with that in the meantime but I just get a catascrophic failure in Blend when adding that.

    Also, the help file still doesn't have the RadDatePicker in the TOC.

  2. Hristo
    Hristo avatar
    832 posts

    Posted 02 Oct 2008 Link to this post

    Hi Roy,

    This is one of the breaking changes that we introduced in order to be more WPF compatible.
    Now SelectionMode enumeration is in System.Windows.Controls namespace. You should updated the namespace.

    If you have any other questions do not hesitate to contact us.

    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Back to Top