Enable Project not an option?

Thread is closed for posting
6 posts, 0 answers
  1. Mike
    Mike avatar
    1 posts
    Member since:
    Oct 2008

    Posted 12 Nov 2010 Link to this post

    Hi Telerik team,

    I have just installed Open Access Express into VS2008 (Academic Pro edition). The Open Access install seems fine, however, when I start watching and going through the steps in


    Then right clicking on the new project (a windows console application as per the video) and going down to OpenAccess the only options I get are:
    -  Add domain model
    -  Add domain service (greyed out not an option)
    -  Upgrade references
    -  Convert to domain model (greyed out)

    The video mentioned above shows 4 completely different options, of which one is enable project. Similarly, looking under the Telerik
    dropdown on the main menu bar I get the Data Services Wizard (which looks to be for projects already containing OpenAcess entities), and then under OpenAccess I get the same 4 options I've listed plus Help/Options/Product Info but still no enable project.

    If I open up a pre-existing project, for instance the web project I'm thinking of using OpenAccess for, then I also don't see Enable Project anywhere.

    Please can you let me know if I'm missing something or need to do something differently.

    Also under Add New Item, I can't see any Telerik Templates. I'm using sql2008 express, which is an upgrade from a full version of 2005 if that makes a difference although I don't see that it should.

    Hoping you can help.

  2. Serge
    Serge avatar
    375 posts

    Posted 16 Nov 2010 Link to this post

    Hi Mike,

     First of all, I'd like to underline that we are currently providing support for both OpenAccess Classic and the new OpenAccess Visual Designer. What you are looking for is the OpenAccess Classic menus, which are hidden by default since the Q2 release. There is an easy step you can do in order to get them back and you can read about it in this blog post.

    If you are planning on only using the Classic approach you should skip the following paragraphs.

    However the fact that you are not seeing any templates in the Add new item wizard which worries me. Have you installed OpenAccess in the default directory or did you specify a custom one. Can you please check that the C:\Program Files (x86)\Telerik\OpenAccess ORM\dsl2010\CSharp\1033 directory contains the EntityDiagrams.zip which is the template for the designer item. Also please have a look at the C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\ItemTemplates\CSharp\Data folder for the same file. If they are missing I would suggest performing a clean uninstall and installing the latest version again. 

    I am looking forward to resolving this issue.

    Best wishes,
    the Telerik team
    See What's New in Telerik OpenAccess ORM in Q3 2010!
    Monday, November 15, 11 am Eastern Time: Register here>>
    Monday, November 15, 10 pm Eastern Time: Register here>>
  3. Martin
    Martin avatar
    2 posts
    Member since:
    Sep 2010

    Posted 06 Jan 2011 Link to this post

    Hi team

    I've recently reinstalled my development PC and joined it onto a Windows 2008 domain and have the same problem with the classic release.  The options to enable a project is missing.  I've done a clean uninstall as well as a reinstall using the domain administrator login and this did not resolve my problem at all.  Adding my user to the local Administrators group did not help either.  When opening an existing project with VS2010 again, I received the following error message (highlights listed - removed references to the exact file, etc):
    Unable to read the project file 'Model.csproj'.  Access to the path 'C:\Program Files (x86)\MSBuild\OpenAccess.targets' is denied

    This I traced to the following line in the .csproj file:
    <Import Condition="Exists('$(MSBuildExtensionsPath)\OpenAccess.targets')" Project="$(MSBuildExtensionsPath)\OpenAccess.targets" />

    If I comment this line out, the project loads fine and builds successfully as well.

    Are there perhaps any clashes with some of the Microsoft released patterns and practices components that is causing the issue relating to the missing options?

    If I can provide any other information in order to assist and resolve this, it would be great.

  4. Jordan
    Jordan avatar
    547 posts

    Posted 06 Jan 2011 Link to this post

    Hi Mike,

    It would help to know what version of OpenAccess are you using?

    But if you are using a recent version then probably the reason for you not seeing the enable project menu items is that they are hidden by default. As Serge explains in his post you can easily switch to the OpenAccess Classic menus and have these menu items available.

    About the other issue that you mention, indeed it seems that your Model project cannot be loaded because of the OpenAccess.targets file.
    Unfortunately the OpenAccess.targets file is very important for the functioning of OpenAccess. Without it the OpenAccess enhancer will not be invoked which will cause the generated entities and context not to work correctly.

    We have never had such a case reported, but it seems that for some reason your user has limited rights for the OpenAccess.targets file or the directory that contains it.
    You could check that your user has at least read and execute rights for the directory and the .targets file.

    It will help to know what version of Windows are you using on you development PC?
    It is possible to have different access rights depending on the version of Windows that you are using.

    Also, is it possible that some permissions are applied due to domain policy or something?

    Another thing that you could do is try to set UAC to the least aggressive / protective setting.

    Looking forward to resolving this issue.

    All the best,
    the Telerik team
    Accelerate your learning with industry's first Telerik OpenAccess ORM SDK. Download today.
  5. Martin
    Martin avatar
    2 posts
    Member since:
    Sep 2010

    Posted 10 Jan 2011 Link to this post

    Hi Team

    Okay, after a weekend of pulling my hair out and getting no sleep, I managed to find out where the real problem was.  I reinstalled my development PC probably close to 10 times to try and simulate where the differences were and eventually got it to work.  And then when I tried to reinstall it again this morning with the sample databases, it broke again and I was a broken man.  So I opted to see where the differences where and found the easy solution.

    First, my environment is as follows:
    • Windows 7 64-bit with all updates installed
    • SQL Server 2008 R2 (Enterprise and Express running as 2 seperate instances - Express for samples and Enterprise for development)
    • Office 2010
    • Visual Studio 2010 Professional
    • Expression Studio 4

    I also have 2 accounts:

    • Administrator (in Administrators group)
    • Developer (in Users and SQL Development group)

    All installations were done using the Administrator account, except for OpenAccess ORM which prompted me for the Administrator password.

    When the issue came up again this morning, I figured to try and use the Administrator account and see if everything was available, and lo and behold, everything was there, which led me to the resolution as described below.

    Basically the issues that were occuring are related to User Access.  The following files did not inherit their security settings from their parent paths, which causes the nightmares:

    • C:\Program Files (x86)\MSBuild\OpenAccess.targets
    • C:\Program Files (x86)\Telerik\OpenAccess ORM\sdk\IDEIntegrations\Microsoft Visual Studio 2005\addin\*.AddIn

    I changed these permissions and everything was resolved - the add-in available in Visual Studio and everything.  I just haven't had a chance yet to compile my projects, but I don't foresee any problems with it.  I will do a reply as soon as I have done this.

    On an aside, is there a way for me to download the sample databases for OpenAccess and Reporting manually so I can attach it to my SQL Express instance and run the demo applications?

    I hope this helps out a lot of other guys as well that can have similar issues - please advise your developers also to keep a lookout for requiring the Administrators group/Administrator user to use the application; this seems to have popped up in this case and Microsoft is very anti-Administrator use with their security drive.

    PS Any reward for resolving this? :-)

  6. Dimitar Kapitanov
    Dimitar Kapitanov avatar
    632 posts

    Posted 12 Jan 2011 Link to this post

    Hello Mike,
    We are still not able to reproduce such behavior in our testing environment, therefore it might be result of the local state of your machine. Nevertheless you pointed us to a direction that we didn't tested extensively and your Telerik points were updated.

    All the best,
    Dimitar Kapitanov
    the Telerik team
    Accelerate your learning with industry's first Telerik OpenAccess ORM SDK. Download today.
Back to Top