This is a migrated thread and some comments may be shown as answers.

Disabling top level menu animation

3 Answers 106 Views
Menu
This is a migrated thread and some comments may be shown as answers.
James
Top achievements
Rank 1
James asked on 24 Apr 2010, 05:55 AM
Hello,

Can you please recommend the best way to disable the default animation - I just want the top level menu to appear and dissappear instantly.

I have looked at http://www.telerik.com/help/silverlight/radmenu-features-animation.html but there is no mention of disabling animation. I have tried setting SpeedRatio to zero, but this had no affect, then I tried removing the Animation Selector from the RadMenu template, but the default animation still executes.

Help appreciated,

James.

3 Answers, 1 is accepted

Sort by
0
James
Top achievements
Rank 1
answered on 24 Apr 2010, 07:51 AM
Actually, the default animation has gone but there is still a fade in effect when a menu is opened - that is what I'm trying to disable.

There is no issue with closing a menu, a fade out effect animation does not start, so no problems there.

Any ideas?

James.
0
Accepted
Kaloyan
Telerik team
answered on 28 Apr 2010, 08:59 AM
Hello James,

What you need to do is to disable the global animation of the control. To achieve it use the following property in your constructor:

AnimationManager.IsGlobalAnimationEnabled = false;

Regards,
Kaloyan
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
James
Top achievements
Rank 1
answered on 28 Apr 2010, 09:39 AM
Thanks that worked.
Tags
Menu
Asked by
James
Top achievements
Rank 1
Answers by
James
Top achievements
Rank 1
Kaloyan
Telerik team
Share this question
or