Detaching doesn't seem to work

Thread is closed for posting
2 posts, 0 answers
  1. Geoffrey
    Geoffrey avatar
    23 posts
    Member since:
    Mar 2011

    Posted 14 May 2013 Link to this post

    I have tried the 'detach profilee' option and disable profiling, but neither seem to work. I started profiling an application (attach to existing process), then wanted to compare results with another profiler (Ants) but it could not attach because JT was still attached (even after exiting JT). Starting JT again, when it loaded the list of processes it showed that the process I previously p attached to was still sampling, so it seems like the detaching didn't work.
  2. Kaloyan
    Kaloyan avatar
    878 posts

    Posted 16 May 2013 Link to this post

    Hi Geoffrey,

    Thank you for reporting this.

    You are correct that the JustTrace profiler remains attached to a running process even after Detach Profilee has been hit. You are also correct that stopping or restarting JustTrace is not changing the above either. It is unfortunate to say but for now, the only way to remove our profiler from the profiled process is to restart that process.

    This is due to the fact, the Detach Profilee button is only disabling the JustTrace profiler inside the profiled process and saving the current session afterwards. This means the Detach Profilee button is almost the same as Kill Profilee (when profiling a .NET Executable, for example), but instead of killing the profiled process it leaves the JustTrace profiler disabled in it. So, to actually detach our profiler from a once profiled .NET running process, you will need to restart that current process, the same as other profilees being automatically killed by JustTrace (Kill Profilee) when the profiling session has ended.

    I hope this helps.

    the Telerik team
    Share what you think about JustTrace & JustMock with us, so we can become even better! You can use the built-in feedback tool inside JustTrace, our forums, or our JustTrace or JustMock portals.
Back to Top