This is a migrated thread and some comments may be shown as answers.

Debugging in simulator crashing the simulator

2 Answers 62 Views
AppBuilder Windows client
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Matt
Top achievements
Rank 1
Matt asked on 27 Mar 2014, 06:24 PM
When I hit the debug icon the simulator crashes. I have tried to uninstall Appbuilder and re-install it but am getting the same result.  Here is a stack trace from even view any help would be appreciated I am stuck at this point.

Application: Icenium.Simulator.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.DirectoryNotFoundException
Stack:
   at System.IO.__Error.WinIOError(Int32, System.String)
   at System.IO.FileStream.Init(System.String, System.IO.FileMode, System.IO.FileAccess, Int32, Boolean, System.IO.FileShare, Int32, System.IO.FileOptions, SECURITY_ATTRIBUTES, System.String, Boolean, Boolean, Boolean)
   at System.IO.FileStream..ctor(System.String, System.IO.FileMode, System.IO.FileAccess, System.IO.FileShare)
   at Telerik.BlackDragon.Client.Modules.WebBrowser.WebBrowser.HandleDevTools(System.String, System.IO.Stream ByRef, System.String ByRef)
   at Telerik.BlackDragon.Client.Modules.WebBrowser.WebBrowser.OnRequestResource(CefSharp.IWebBrowser, CefSharp.IRequestResponse)
   at CefSharp.Wpf.WebViewEx.raise_RequestResource(CefSharp.IWebBrowser, CefSharp.IRequestResponse)
   at CefSharp.Wpf.WebViewEx.OnRequestResource(CefSharp.IWebBrowser, CefSharp.IRequestResponse)
   at CefSharp.Wpf.WebViewEx.OnBeforeResourceLoad(CefSharp.IWebBrowser, CefSharp.IRequestResponse)
   at <Module>.CefSharp.ClientAdapter.OnBeforeResourceLoad(CefSharp.ClientAdapter*, CefRefPtr<CefBrowser>*, CefRefPtr<CefRequest>*, CefStringBase<CefStringTraitsUTF16>*, CefRefPtr<CefStreamReader>*, CefRefPtr<CefResponse>*, Int32)

2 Answers, 1 is accepted

Sort by
0
Nepeka
Top achievements
Rank 1
answered on 31 Mar 2014, 06:58 AM
Just looked at the other posts in the forum. Deleting the contents of the Cache folder in [User]\AppData\Local\Telerik\BlackDragon\Cache\ helped. Now it is not crashing anymore.
0
Iva Koevska
Telerik team
answered on 31 Mar 2014, 12:55 PM
Hello Marc,

As Nepeka stated, you can try the following workarounds. Start with the first and if it doesn't help, try the second one.

Workaround #1:
Close instances of the Windows client, kill any leftover Icenium.Graphite.exe processes and delete the contents of %localappdata%\Telerik\BlackDragon\Cache

Workaround #2:
1. Close all instances of the Windows client and kill any leftover Icenium.Graphite.exe processes.
2. Uninstall the Windows client from the Control Panel.
3. Go to %localappdata%\Telerik and delete the BlackDragon folder and its contents.
4. Go to %localappdata%\Apps and delete the 2.0 folder and its contents.
5. Install the Windows client again.

Regards,
Iva Koevska
Telerik
 

Build cross-platform mobile apps using Visual Studio and .NET. Register for the online webinar on 03/27/2014, 11:00AM US ET. Seats are limited.

 
Tags
AppBuilder Windows client
Asked by
Matt
Top achievements
Rank 1
Answers by
Nepeka
Top achievements
Rank 1
Iva Koevska
Telerik team
Share this question
or