DataFormatString causes VS 2010 exception and CTD

4 posts, 0 answers
  1. Rob Ainscough
    Rob Ainscough avatar
    262 posts
    Member since:
    Jan 2010

    Posted 29 Aug 2012 Link to this post

    When editing the DataFormatString in my XAML in VS 2010 SP1 for a Telerik GridViewDataColumn like:

    <telerik:GridViewDataColumn Header="Date" MaxWidth="80" MinWidth="80" Width="80" DataMemberBinding="{Binding ToDoSystemDate}" TextAlignment="Right" DataFormatString="{}{0:dd, MMM, yyyy}"/>

    Will cause VS 2010 to crash to the desktop with the following error:

    Visual Studio has encountered an exception.  This may be caused by an extension. ...

    I'm running version 2012.2.607.1050 of RadControls.  Is this a known bug?  I have the v 2012.2.725.1050 downloaded but not installed yet ... but no mention this was fixed in .725.

    Any info on this?

    Thanks, Rob
  2. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 30 Aug 2012 Link to this post

    Hi,

     I've tried this however everything worked as expected on my end. Please check the attached screenshot for reference. 

    Kind regards,
    Vlad
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. Rob Ainscough
    Rob Ainscough avatar
    262 posts
    Member since:
    Jan 2010

    Posted 30 Aug 2012 Link to this post

    Not sure what to say Vlad,  the only extensions I have installed are Telerik.

    But this is going to be very diffucult to duplicate your end and I can't send you my entire solution (too sensitive and not even NDA would be good enough).  VS 2010 memory usage at the time isn't too bad 432,100K (my PC has 32GB but no where near the 2GB/3GB 32bit thread limit).

    To be clear, it happens while typing in the DataFormatString=" .... (typing here) ... " -- but sadly it does NOT always happen.  But when it does happen, it ONLY happens when I'm editing XAML for telerik:GridViewDataColumn.

    Rob
  4. dani
    dani avatar
    48 posts
    Member since:
    Jan 2011

    Posted 14 Dec 2012 Link to this post

    I get the same error, and after playing a little with the string - it crushes VS 2010 sp1.
    IT pops up when I add the 0 into the string: DataFormatString="{0:dd/MM/yyyy}"

    it will also not compile....
Back to Top