CUD mapping not working

Thread is closed for posting
3 posts, 0 answers
  1. Jason Maronge
    Jason Maronge avatar
    321 posts
    Member since:
    Jan 2005

    Posted 10 May 2011 Link to this post

    I am trying to us the Map Procedure functionality for my object and it maps the stored procedures in the Mapping Details Editor.  I have added those procedures to my database but every time I call update it tries to run a prepared statement and failes.  I have modified the update statement inside the procedure so I can do something different with it so I really need it to call the procedure specified.  What could be going wrong?

    What I have is a view as an object that returns some other fields with my object but when I save it I don't want those extra fields from another table to be updated so I have taken them out of the update, and insert statement of the generated procedures.  I hope this makes sense.

    I have updated and tried the latest internal build 510.

    The procedure names are:

  2. Jason Maronge
    Jason Maronge avatar
    321 posts
    Member since:
    Jan 2005

    Posted 11 May 2011 Link to this post

    Essentially I am trying to do this:

    I have modified the store procedures so they only update the table I am trying to work with.

    I have tried to get the stored procedures to work with a regular table and it does not work their either.  OA keeps using the prepared statements for regular tables that are mapped to stored procedures also.

  3. Damyan Bogoev
    Damyan Bogoev avatar
    581 posts

    Posted 13 May 2011 Link to this post

    Hi Jason Maronge,

    It seems that the issue is related to the Mapping Type when it is set to Attributes. You should change it to XML. The following help article shows how to achieve that goal.
    Hope that helps.

    Damyan Bogoev
    the Telerik team
    Q1’11 SP1 of Telerik OpenAccess is available for download; also available is the Q2'11 Roadmap for Telerik OpenAccess ORM.
Back to Top