CryptographicException Unspecified error (decrypting SSL traffic)

3 posts, 0 answers
  1. dan
    dan avatar
    8 posts
    Member since:
    Jul 2018

    Posted 30 Jul Link to this post

    I am having problems decrypting any SSL traffic on my Windows 10 PC.

    I have tried Eric's post on resetting certificates to no avail.

    I am seeing this on all SSL requests, this one is for the first request to fiddler to check for fiddler updates, for example: 

    09:50:02:3744 fiddler.network.https> HTTPS handshake to www.fiddler2.com (for #1) failed. System.Security.Cryptography.CryptographicException Unspecified error

    To try and isolate the issue I installed Charles and it is able to decrpyt SSL requests so I dont believe it is a system-wide / local network issue.

    Any help much appreciated as Fiddler is such an excellent tool.

  2. dan
    dan avatar
    8 posts
    Member since:
    Jul 2018

    Posted 31 Jul in reply to dan Link to this post

    So I have now got Fiddler working again, these steps fixed my problem:

    • Remove Fiddler certificates (via the GUI, and manually check in Certificates mmc)
    • Uninstall Fiddler, including all settings data
    • Use a registry cleaner to clean up orphan / broken entries
    • Delete any remnant folder related to Fiddler
    • Download latest version of Fiddler
    • Install using all defaults (dont install to a custom location)
    • Set HTTPS Capture and Decrypt in Fiddler
  3. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 02 Aug Link to this post

    Hello,

    Glad to hear you figured it out. Usually, clearing the certificates is sufficient, but it seems that didn't worked out in this case.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top