This is a migrated thread and some comments may be shown as answers.

CommitRowEdit scrolls to top

4 Answers 44 Views
GridView
This is a migrated thread and some comments may be shown as answers.
Joachim
Top achievements
Rank 1
Joachim asked on 26 Jan 2011, 10:39 AM
Hello Telerik Team !

I need your help for a problem that annoyes my customer when he uses the radgridview.
I'm using the version 2010.3.1213.1040 of Telerik Silverlight RadGridView.

I have an application that uses the radgridview and uses explicit button to switch to edit/save/cancel mode (see screenshot grid_snap.png).
Only one row can be edited at a time.

This is the method call when the user click on the save button
private void btnSave_Click(object sender, RoutedEventArgs e)
{
      radGridViewSimulations.CommitRowEdit(_currentRowEdited);
      radGridViewSimulations.UnselectAll();
}


The problem is when the user click on the save button the grid automatic scrolls to the top... and my customer has to scroll again until he founds the row commited... 

What do i do wrong ? How can i prevent the grid to be automatically scroll at top when it's commited ?

Please tell me if your need more precision.
Thank you for your help !

Joachim.




4 Answers, 1 is accepted

Sort by
0
Maya
Telerik team
answered on 26 Jan 2011, 11:01 AM
Hi Joachim,

I have tried to reproduce the issue you reported, but I was not able to. I am sending you the sample project I used for testing it. Please take a look at it and let me know in case it does not simulates your scenario. 
 

Kind regards,
Maya
the Telerik team
Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
0
Joachim
Top achievements
Rank 1
answered on 16 Mar 2011, 05:02 PM
I was able to reproduce the issue.
I have just changed some code in the attached project.
I send you a support ticket : id = 403952

Thank you for your help.

Joachim.
0
Accepted
Maya
Telerik team
answered on 17 Mar 2011, 02:02 PM
Hello Joachim,


Generally, this behavior is a kind of an expected one since you are setting the DataLoadMode property to "Asynchronous". In this case the state will be reset thus leading to jumping to the top of the grid. 
On the other hand we do have a lot of performance improvements in our current official release Q1 2011 and you may freely take advantage of it. Consequently, there will be no necessity of using an asynchronous mode. 


Greetings,
Maya
the Telerik team
0
Joachim
Top achievements
Rank 1
answered on 18 Mar 2011, 12:13 PM
The issue is fixed in the last release Q1 2011. 
Thank you !
Tags
GridView
Asked by
Joachim
Top achievements
Rank 1
Answers by
Maya
Telerik team
Joachim
Top achievements
Rank 1
Share this question
or