This is a migrated thread and some comments may be shown as answers.
Column Field Names have double quotes, causing lots of issues with other applications
3 Answers 73 Views
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
JDT
Top achievements
Rank 1
JDT asked on 25 Sep 2009, 05:05 AM
Hi Telerk,

As always I appreciate your quick responses. I have looked all over the forums and have not found an answer to my problem. We are using ORM with Oracle 10G2.

For some reason all my field/column names for forward mapped tables are created with "s (double quotes) for example.

Table Person
Field "Person_First"
Field "Person_Last"

Any tool that queries (SQL Developer, programs, etc) that allow a query to be run, have to surround the fields with " " and have to have the correct case. This is incredibly annoying as quering on the fly, stored procedures, reports and other apps have to take this into account.

For example
Select * from Person where Person_First = 'Andy' << does not work
Select * from Person where "Person_First" = 'Andy' << works

I saw an xml param on one post called <useDelimitedSQL>false</useDelimitedSQL> however there is no documentation on this. Not to mention we already created all our tables. I went I modified one field and removed the " " s, saved it. Now it doesn't work..I went back and added the " " around the name and oracle won't save it out with quotes again... This is making our lives really difficult.

We have all sorts of things that need to work with these tables, and we can't implement ORM on all of them ;).

Please let me know what to do and how to retrofit all my tables to get this working right. Thanks!

3 Answers, 1 is accepted

Sort by
0
Ady
Telerik team
answered on 29 Sep 2009, 02:47 PM
Hi JDT,

 OpenAccess delimits column names in order to allow spaces and keywords in the column names.
The <useDelimitedSQL>false</useDelimitedSQL> can be used to turn this off.

Note that if you turn this off the generated SQL will not be delimited and identifiers for tables,columns, constraints and indexes  cannot contain whitespaces, reserved words and dots.

Regards,
Ady
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
JDT
Top achievements
Rank 1
answered on 01 Oct 2009, 08:00 PM
Where exactly do we insert these tags? The <UseDelimitedSql> ones. Also if we do this to our current mapping (with tables that have already been created and have data in them), will we break them?

Thanks.
0
Ady
Telerik team
answered on 02 Oct 2009, 12:31 PM
Hi JDT,

 This entry should be placed under the <backendconfiguration> node (where the 'mappingname' node is present) in the app.config file.

This setting will apply to tables created henceforth. Existing tables are not modified as Oracle does not distinguish between delimited and non-delimited names during schema retrieval.

Sincerely yours,
Ady
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Tags
General Discussions
Asked by
JDT
Top achievements
Rank 1
Answers by
Ady
Telerik team
JDT
Top achievements
Rank 1
Share this question
or