Code Sync Error - Cant commit workspace

4 posts, 0 answers
  1. Jason
    Jason avatar
    21 posts
    Member since:
    Apr 2013

    Posted 11 May 2013 Link to this post


    Earlier today I chose to commit my code from my server which lead to an unknown error in graphite.  Essentially the commit failed and I tried again.
    On the second time I received no warning or error and so thought it had completed successfully.

    Later in the day, on a laptop, I opened my workspace on graphite and started working. It was only later that I noticed that the changes made in the morning were not in the code I was working on. I was now in a state where I had one code base with a fair amount of changes , minus the code changes from earlier in the day. 

    I've had to manually resolve this issue (carefully) and now want to push the changes on the laptop back to the repository. 
    I'm now in a position where I am stuck as I have 9 items that were removed from the solution and so when I try to commit my workspace from my laptop, it fails as it can not find those assets on this machine (They are on the one from earlier in the day)  

    What options are available to resolve this?  Apart from doing a release, it stops any updates going through to ION as I cannot push up all of the changes. 

  2. Jason
    Jason avatar
    21 posts
    Member since:
    Apr 2013

    Posted 12 May 2013 Link to this post

    As an update, I still ave the case where ICENIUM graphite shows one view (the final state I want) and mist shows another. 

    Actually, I've spent a lot of pain going through and adding the files that were deleted (and no longer on my machine) back onto my machine, adding them back into the project, commiting them, then deleting them again and commiting. 

    While this apporach does work, upon commiting I get an error "Unknown error" but it looks like the change goes through. If I then load up a mist instance, I can see the file has not gone. Mist still shows some ghost files that I will have to delete separately but it look slike after some more manual effort, I should be able to get my workspace back into a good shape.  

    The only point of concern/annoyance  is now whenever I commit a source package, I get the "Unknown error" has occurred dialog before it actually goes through and does the commit. Ill admit this has me unsettled but when I reload up the solution the changes do seem to have gone through so that's one good thing.

  3. Steve
    Steve avatar
    10941 posts

    Posted 13 May 2013 Link to this post

    Hi Jason,

    Is there a stack trace in the Graphite Errors or Output pane? If not, what about the Graphite logs available in %LocalAppData%\Telerik\BlackDragon\Logs? Please review them from the datetime that you've received the Unknown error and see if there are any errors logged there that contain more than just "Unknown error" and zip and provide those logs for us to review. We also suggest running FiddlerCap (with the Decrypt HTTPS Traffic option enabled) before launching Graphite and save the HTTP requests Graphite performs to disk and send those our way as well.

    If there isn't anything relevant in the logs, can you share which is the project you get this error on and do we have your consent to take a look at it?

    All the best,
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
  4. Jason
    Jason avatar
    21 posts
    Member since:
    Apr 2013

    Posted 14 May 2013 Link to this post

    Hi Steve

    Thanks for the follow up. No errors were displayed in the window or in the output pane. Ill have a look at the server desktop where this originated from.  There is indeed log files in the location you specified. Ill see if I can find anything of use in them and if relevant, send them on to the team just as a reference. 

    As it stands now, things are working. I did a clean up of the workspace by switching between mist and graphite.  Graphite was allowing me to commit (after the "Unexpected error" dialog) but would not show files I had deleted previously and were still visible in mist. (I used Mist to remove this orphaned files)

    Because of this, I believe I sorted things out. I've just submitted an app built with icenium to the app store and on final commit, no errors occurred. So things were good all round. (Submitted the app via graphite which worked well) 
Back to Top