This is a migrated thread and some comments may be shown as answers.

CLR Namespace Erros & "missing an assembly reference"

2 Answers 47 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Paul Exler
Top achievements
Rank 1
Paul Exler asked on 25 Oct 2012, 01:24 PM
Hi there.

I get several Errors which doesnt help me even a little to understand how i can fix it.

We updated a bigger project from Version
2012.2.725.1050  to  2012.3.1017.1050

We ensured already some errors in our resourcedictionary after updating to 2012.2.725.1050
but this became even more confusing after updating to 2012.3.1017.1050

We get a lot of
"Undefined CLR Namespace" Errors,
as well as "the type *XY* was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been build"

In this little TestApplication

i simply made following steps:
- created a new silverlight web-project
- Added the control RadMaskedNumericInput via Blend (version 5.2)
- Added a ResourceDictionary
- Made a "Edit a copy..." of the Control into the ResourceDictionary

When i run the solution it works as it supposed to be. When i "rebuild" the solution in VS, everything seems to be okay, no errors.
But when i only edit a simple thing in the resource dictionary (by VS), something like adding a spacer in a comment, it shows the errors as described above.

I hope this description with the TestApplication helps to find out what it is.

PS.: We had much more difficult Errors in our main project which have been confusing.
Deinstalling of 'Kendo UI' helped a lot to remove most of the errors.
We have the same problems with other telerik controls too.
So the Testapplication shows only the example with the RadMaskedNumericInput.

2 Answers, 1 is accepted

Sort by
0
Paul Exler
Top achievements
Rank 1
answered on 30 Oct 2012, 09:22 AM
Hi Guys,

we tried the testscenario (downloadlink above) now with Silverlight Controls Q2 and Q3 on another computer with the same errors.

We're using:
- Windows 8
- Visual Studio 2012 Premium (v11.0.50727.1)
- Theres only Telerik Silverlight Controls installed

By the way, the errors wont appear in Blend (v5.2.30810.0)

Thanks for any guess.
0
Accepted
Tina Stancheva
Telerik team
answered on 30 Oct 2012, 01:42 PM
Hello Paul,

This is a known issue caused by VisualStudio 2012. It seems that it doesn't recognize an alias to a namespace unless the namespace is defined with a scheme URL (like xmlns:telerik="http://schemas.telerik.com/2008/xaml/presentation").

Unfortunately at the moment we're not aware of any workarounds.

Regards,
Tina Stancheva
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Tags
General Discussions
Asked by
Paul Exler
Top achievements
Rank 1
Answers by
Paul Exler
Top achievements
Rank 1
Tina Stancheva
Telerik team
Share this question
or