Client side certification failure in non-proxy mode after installing and using Fiddler.

3 posts, 0 answers
  1. Jim
    Jim avatar
    2 posts
    Member since:
    Nov 2016

    Posted 17 Nov 2016 Link to this post

    Hi All, I hope someone can help!

    On a Windows 10 machine, I installed and ran the latest Fiddler version (v4.6.3.44034) and was able to successfully capture and decrypt HTTPS sessions using the proxy server.

    Now, I am trying to return to normal operations, running without the proxy server.  One of the sites requires a client side certificate be attached to the request and this request now fails with error -2146233079 (The request was aborted: Could not create SSL/TLS secure channel).

    This was working just fine prior to the Fiddler install, under the current user, not the admin account.  Fiddler was also installed under the same current user.

    If I run the application as Administrator, it works.  So, how do I undo whatever permissions change that was made by Fiddler which prevents me from accessing the client side certificate that I had no problem accessing before?

    I have tried the following so far:

    1) Fiddler Options > HTTPS > Remove Interception Certificates

    2) Fiddler Options > HTTPS > Rest All Certificates

    3) Uninstalling Fiddler entirely

    Thank you!

  2. Tsviatko Yovtchev
    Admin
    Tsviatko Yovtchev avatar
    549 posts

    Posted 29 Nov 2016 Link to this post

    Hello,

    Fiddler doesn't really do permission changes. Is the client certificate in your user store?

    Regards,
    Tsviatko Yovtchev
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Jim
    Jim avatar
    2 posts
    Member since:
    Nov 2016

    Posted 29 Nov 2016 in reply to Tsviatko Yovtchev Link to this post

    Hi, thanks for the reply.

    The certificate is in the Trusted Root store.  Pre-Fiddler I could access that certificate without any trouble.  Post-Fiddler, I now have to run my application with elevated privileges ("as administrator").   Fiddler may not directly, um, fiddle with permissions but unfortunately something was inadvertently changed.

    Thanks again for any thoughts or advice you may have,

    Jim.

Back to Top