This is a migrated thread and some comments may be shown as answers.

Certificate error on Fiddler for Mac

2 Answers 70 Views
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Shawn
Top achievements
Rank 1
Shawn asked on 30 Mar 2020, 02:13 PM
I am trying to get Fiddler running on a Mac and I keep getting the error that my connection is not private and I can't navigate to any sites, therefore rending Fiddler useless.  I've searched through the forums, but all of the solutions I've found have been for the Windows version.  I have verified that the "Decrypt HTTPS" box is checked, but if there's more that needs to be done on the Mac version, I have not found it.

2 Answers, 1 is accepted

Sort by
0
Eric R | Senior Technical Support Engineer
Telerik team
answered on 31 Mar 2020, 04:29 PM

Hi Shawn,

This might be because the proxy settings are applied to an unexpected network location. Can you confirm the proxy settings are on the correct network adapter for your machine?

For example, if you're using WiFi, ensure the Fiddler Proxy settings are applied to that Network adapter. Alternatively, if Ethernet is in use, verify the Fiddler Proxy settings are applied to that Network adapter.

Another option would be to change the Network Location settings from Automatic to Home. As shown in the below screenshot taken from Apple's Support website.

Please let me know if you need any additional information. Thank you for using the Fiddler Everywhere forums.

Regards,


Eric R | Senior Technical Support Engineer
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
0
Robert
Top achievements
Rank 1
answered on 05 Apr 2020, 10:51 PM
I found that if I go into keychain and trust the fiddler certificate it resolves this issue. The certificate explicitly says DO NOT TRUST in the name, so I’m not sure if this is bad practice, but it did resolve my issue.
Asked by
Shawn
Top achievements
Rank 1
Answers by
Eric R | Senior Technical Support Engineer
Telerik team
Robert
Top achievements
Rank 1
Share this question
or