Can’t see the contents of HTTP Tunnel to port 443

6 posts, 0 answers
  1. Russell
    Russell avatar
    3 posts
    Member since:
    Mar 2018

    Posted 21 Mar Link to this post

    Hi,

    I have HTTPS Decryption enabled and I have gone through all the steps to have my iOS device proxy through my PC INCLUDING trusting the fiddler CA cert from General>About. I know the Decryption I’d working because I can see the contents of other HTTPS requests in my session list. If it helps, I suspect that the traffic I’m attempting to inspect is an HTTP upgrade handshake for a web socket connection.

    on other threads it seems like people are describing the same issue I’m having but the solutions are always: “enable HTTPS Decryption” or “regenerate your certificate” or “regenerate your private keys” but I do not think these are the solutions because I have tried all of them except the private key regeneration one and I am able to see the decrypted results of other HTTPS requests. 

    thank you

  2. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 27 Mar Link to this post

    Hi,

    Do you see the "Tunnel To" "xxx.xxx:443" session? Also, does the app/website work properly when the traffic is going through Fiddler?

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Russell
    Russell avatar
    3 posts
    Member since:
    Mar 2018

    Posted 27 Mar in reply to Alexander Link to this post

    Yes and yes. 
  4. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 29 Mar Link to this post

    Hi,

    If you are trying to inspect a WS upgrade request then it should be following the "Tunnel To" session (assuming that there is no other traffic it should be the next one). It can be easily recognized by the WebSocket logo/icon in front of the session.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Russell
    Russell avatar
    3 posts
    Member since:
    Mar 2018

    Posted 03 Apr in reply to Alexander Link to this post

    Following the "Tunnel to" session, none of the subsequent sessions have the WebSocket symbol and none of them are going to the socket's url even though I have no filters enabled.

     

    Russell

  6. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 05 Apr Link to this post

    Hi,

    In order to be sure that Fiddler is not hiding the session you can go to Help -> Troubleshoot. This will enable "Filter troubleshooting", which will show all sessions and those which would be normally hidden will be shown with strike-through font.

    On the other hand, some apps use the so called "Certificate pinning". However, when we've seen such apps they refuse to work with Fiddler and does not load at all. In your case it works, so it seems that this is not the problem.

    Another thought - when you inspect the tunnel session there will be presented information about the HTTPS handshake. You can check it, maybe the answer could be there.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top