Can't configure multiple databases

Thread is closed for posting
2 posts, 0 answers
  1. tmlipinski
    tmlipinski avatar
    131 posts
    Member since:
    Dec 2006

    Posted 04 Mar 2009 Link to this post


    I'm trying to do reverse mapping from 2 databases (let's name them: DB1 and DB2). DB1 is my default database (written in the .config file in the "connections" section). I've started the reveres mapping dialog, used the "Options" button and then - "Databases" button. I've checked required databases (no name for DB1 (as it is the default db) and DB2 for DB2) and accepted the dialog. Finally I've tried to merge schemas; but this time I've got a message:
        Unable to change database: 'USE [DB2]' failed.
    Both databases are configured identically. If I put DB2 as a primary database the reverse mapping dialog connects with it without any problem - but reports this time: Unable to change database: 'USE [DB1]' failed.
    What should I do?

    And by the way, another question concerning multiple databases:
    - DB1 has TB1 table with 2 columns: TB1_id (obvious) and TB1_name
    - DB2 has TB2 table with TB2_FK column that contains foreign keys to DB1.TB1
    If I get a tb2 object (that is a record from TB2) - can I read tb2.TB2_FK.TB1_name? Can I execute a query like this:
        select * from TB2Extent where TB2_FK.TB1_name = 'xxx'

  2. Ady
    Ady avatar
    589 posts

    Posted 06 Mar 2009 Link to this post

    Hi Tomasz,

     I could reproduce that and that seems to be a regression. We have fixed it and it will be available in the next release.
     Regarding your second question - Yes, you can query for records that reference tables from the other database.

    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top