This is a migrated thread and some comments may be shown as answers.

Can't start on Manjaro Linux (ArchLinux)

3 Answers 117 Views
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Samuel
Top achievements
Rank 1
Samuel asked on 20 Dec 2019, 10:26 AM

If I try to start the appimage-File as User I got this: 

[4022:1220/111702.904524:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_progrerhEclj/chrome-sandbox is owned by root and has mode 4755.

 

If I start it as root, the install dialog is shown, but after finish no App-Icon is found, no entry in the Menu and also the app isn't starting.

What to do?

Enviroment:

Manjaro Linux
Linux 4.14.158-1-MANJARO #1 SMP PREEMPT Fri Dec 6 07:01:33 UTC 2019 x86_64 GNU/Linux

 

3 Answers, 1 is accepted

Sort by
0
Eric R | Senior Technical Support Engineer
Telerik team
answered on 23 Dec 2019, 01:09 PM

Hi Samuel,

Thanks for trying this out on Manjaro. Although, this is a known issue with Linux Desktop Environment. Currently this is being worked on and is scheduled for release in Fiddler Everywhere 0.6.0. The release is tentatively scheduled for January 23rd, 2020.

As a token of gratitude for your feedback, I have added a vote for you to the feedback item and encourage following it to receive future updates. 

In the meantime, please let me know if you have any additional questions. Thank you for trying Fiddler Everywhere.

Regards,


Eric R | Technical Support Engineer
Progress Telerik

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
qiao
Top achievements
Rank 1
answered on 27 Jul 2020, 02:13 PM

I encountered the same issue.

```

[8989:0727/220513.696997:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_fiddle4WxzEm/chrome-sandbox is owned by root and has mode 4755.
[1]    8989 trace trap  ./fiddler-everywhere-0.11.0.AppImage

```

environment:

Linux pc 5.3.0-3-amd64 #1 SMP deepin 5.3.15-6apricot (2020-04-13) x86_64 GNU/Linux

0
Lini
Telerik team
answered on 29 Jul 2020, 06:15 AM

Hello,

Can you try to enable user namespaces if they aren't already? You can try it by executing the following command:

sysctl kernel.unprivileged_userns_clone=1

You can also try running Fiddler Everywhere with disabled sandbox with the following command line argument:

 ./fiddler-everywhere-0.11.0.AppImage --no-sandbox

 

Regards,
Lini
Progress Telerik

Asked by
Samuel
Top achievements
Rank 1
Answers by
Eric R | Senior Technical Support Engineer
Telerik team
qiao
Top achievements
Rank 1
Lini
Telerik team
Share this question
or