This is a migrated thread and some comments may be shown as answers.

Assembly caching not outputing zip files

1 Answer 21 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Russell Mason
Top achievements
Rank 1
Russell Mason asked on 13 Jun 2010, 10:48 PM
Hi

I am having a problem with Telerik controls and assembly caching. I have read your blog
http://blogs.telerik.com/blogs/posts/10-01-04/application_library_caching_in_radcontrols_for_silverlight.aspx
which implies that this should just work by ticking the 'Reduce XAP Size' check box.

However, when I do this I get the System assemblies output to zip files but not the Telerik controls. My understanding is all that is needed is the extmap.xml file (which you provide and is in my program files folders next to the assemblies). I also need to set the Copy Local to true. These assemblies still end up in my XAP file though.

Any ideas as to what else might cause this?

Thanks
Russell Mason

1 Answer, 1 is accepted

Sort by
0
Russell Mason
Top achievements
Rank 1
answered on 14 Jun 2010, 01:25 AM
OK, I have sorted this now. For anyone else who may get this problem it had something to do with the ridiculous Windows feature whereby files downloaded get some kind of blocking flag on them (I recently updated to the latest Telerik controls build downloading the assemlies only). I ran Streams.exe and everything seems fine now.

Thanks
Russell Mason
Tags
General Discussions
Asked by
Russell Mason
Top achievements
Rank 1
Answers by
Russell Mason
Top achievements
Rank 1
Share this question
or