Adding reference to Telerik.Windows.Controls.GridView causes System.Windows not to load

5 posts, 0 answers
  1. Sindre
    Sindre avatar
    5 posts
    Member since:
    Jun 2010

    Posted 27 Oct 2010 Link to this post

    Hi

    I am using version 2010.2.924.1040 of the telerik assemblies and developing on VS2010, Silverlight v4.

    When adding references to assemblies such as the Telerik.Windows.Controls everything is fine and no errors when building etc.
    However when adding a reference to the Telerik.Windows.Controls.GridView.dll i get this error:
    Could not load file or assembly 'System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or one of its dependencies. The system cannot find the file specified. 

    Removing the reference again will make it go away.
    I don't even have to reference or use any of the controls located within the namespace. All xaml pages in the given project will throw the same error upon trying to build.

    I have been googling all day trying to figure out what can cause this. Really stumped here..

    I noticed that System.Windows was not located in my gac so I tried adding it. This almost made VS explode when running the designer, so I removed it again. :)

    Please help me
    Regards
    Sindre

    EDIT!
    Tried the Q3 2010 Beta for silverlight 4. When trying to reference these telerik dll's I got the error:
    "Could not find the file specified"

    Also tried reverting to Silverlight 3 using the 2010.2.924.1030 versions. Not getting any errors now. I'm guessing the problem is my computer, but any tip as to what might resolve the issue will be greatly appreciated.

  2. Sindre
    Sindre avatar
    5 posts
    Member since:
    Jun 2010

    Posted 28 Oct 2010 Link to this post

    Well now. It seems that I'd been a little careless as to what went into the assembly.
    Reverting back to silverlight 3 did not resolve anything, it just moved the problem elsewhere.

    I stumpled across this article:
    http://forums.silverlight.net/forums/p/176271/396823.aspx

    While I was looking another way, some silverlight 3 dll's had snuck their way into my GAC. And this was the root of my agony.
    Removed all dll's with version 2.0.5.0 and everything is back to normal again.
  3. Yordanka
    Admin
    Yordanka avatar
    634 posts

    Posted 28 Oct 2010 Link to this post

    Hello Sindre, 

    A possible reason for this error may be the target silverlight version of your project is different from the version of the referred assemblies, e.g. your application is Silverlight3, but Telerik assemblies version are for Silverlight4.

    Kind regards,
    Yordanka
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. ss
    ss avatar
    37 posts
    Member since:
    Nov 2010

    Posted 29 Feb 2012 Link to this post

    HI,
    i have installed RadControls_for_Silverlight5_2012_1_0215_Dev

    and i updated  all dlls to my projects.

    when i am running iam getting the below issues while opening my screen.

    Could not load file or assembly 'Telerik.Windows.Controls.GridView, Version=2012.1.215.1050, Culture=neutral, PublicKeyToken=5803cfa389c90ce7' or one of its dependencies. The requested assembly version conflicts with what is already bound in the app domain or specified in the manifest. (Exception from HRESULT: 0x80131053)

    i have done my all those trails to resolve this like cleaned the bin and clientbin folders and after installation restarted the solution and machien.but i dont know from whr the conflict issues is coming.

    thanks in advance
  5. Tim
    Tim avatar
    16 posts
    Member since:
    Mar 2012

    Posted 01 Mar 2012 Link to this post

    Same problem for me.  Seems to work fine running in debug on my local machine, but when I deploy to a webserver and hit the page with the Telerik GridView control.  I get the error.
    Tim

    Update:  If I turn off the 'Reduce XAP size by using application library caching', it seems to work (assuming I delete all the cached libraries in the ClientBin directory).  However, I would like to us this feature since it reduces by XAP file 5 fold.  Any ideas?  Didn't have this problem with 2011 Q3.
Back to Top