2013 Q2 SP1 Installer cannot find my VS2008 Pro

Thread is closed for posting
3 posts, 0 answers
  1. Daniel
    Daniel avatar
    2 posts
    Member since:
    May 2013

    Posted 04 Oct 2013 Link to this post

    Hi. I'm new to OpenAccess and i'm trying to install it, but have faced some problems:

    - Downloaded it from the telerik website and tried to install it with Visual Studio 2008 support enabled. After installing it, I tried opening VS and the templates weren't installed.
    - Went to Telerik's control Panel, checked the features of OA, and it didn't have the 2008 support checked. So I checked it again and executed the action, check again in telerik's control panel... not enabled.
    - Tried Repair, Uninstall, download again and reinstall... same.
    - When I went to the downloaded .msi in ProgramData\Telerik\Installer folder and executed directly, that installer didn't even show VS2008 as a clickable/checkable option.

    What am I doing wrong?

    - Windows 7 Home Premium x64
    - VS2008 Professional
    - RadControls Trial installed.
  2. Kristian Nikolov
    Kristian Nikolov avatar
    206 posts

    Posted 09 Oct 2013 Link to this post

    Hello Daniel,

    To install Telerik OpenAccess ORM for Visual Studio 2008 it is enough to select the VisualStudio 2008 Support option from the Telerik Trial Installer.

    Alternatively, if you prefer to install OpenAccess directly from the .msi file, you will be able to select Visual Studio 2008 in the following way:
    1. At the Customization step of the installer, click the Customize button.
    2. From the drop down menu in front of the Visual Studio 2008 option, chose Will be installed on local hard drive.
    You will be able to turn features of OpenAccess on or off from the Telerik Control panel, only if you have installed the product through the Telerik Installer. Therefore if you have installed OpenAccess directly from the .msi file you will be unable to see checkboxes for any version of Visual Studio.

    Please note that OpenAccess Project Templates are available only for Visual Studio 2010 and later versions. So for example, if you to create an OpenAccess Domain Model as a separate project, you will have to:
    1. Create a Class Library project.
    2. Add Telerik OpenAccess Domain Model to the project.

    Could you please confirm whether the OpenAccess Item Templates are available for you and whether the Visual Studio 2008 checkbox in Telerik Control panel is checked (in case you have used Telerik Trial Installer to install OpenAccess)?

    We are looking forward to an update regarding your situation.

    Kristian Nikolov
    OpenAccess ORM Q3 2013 Beta is available for immediate download in your account. Get it now and play with the latest bits. See what's new >>

  3. Daniel
    Daniel avatar
    2 posts
    Member since:
    May 2013

    Posted 10 Oct 2013 Link to this post

    Hi Kristian. I managed to make it work. It turns out that I didn't have SP1 installed. Even so, after I installed it, I still found the following issues:

    - The "Repair" option in the Telerik's Control Panel didn't repair the vs2008 support. I mean, it made it appear and stay checked after repair (which didn't happen when SP1 wasn't installed), but it still didn't actually DO anything inside Visual Studio, no templates, no menu options for adding Domain Models, etc.
    - Only after I uninstalled and reinstalled fully, did the ORM icon appear on the splash screen, and also the OpenAccess menu was added to the Telerik main menu in the IDE.

    In response to you question, no, the Project Templates do not work, but the Item Templates do appear and work perfectly now.

    So, thanks for your time and attention to this matter!
Back to Top