Using Fiddler with VS2010 and chrome

3 posts, 0 answers
  1. Kenneth
    Kenneth avatar
    104 posts
    Member since:
    Apr 2014

    Posted 16 Dec 2016 Link to this post

    Trying to get fiddler to work in visual studio 2010 using chrome when run from the IDE

    On the development machine the url looks like http://localhost:someport/somefile.aspx

    I set a static port in the VS project properties and told fiddler to monitor that port - nothing.

    modified the .net framework machine.config to run on a proxy per internet suggestions - nothing

    <system.net> <defaultProxy useDefaultCredentials="true" enabled="true"> <proxy autoDetect="false" bypassonlocal="false" proxyaddress="http://127.0.0.1:8888" usesystemdefault="false" /> </defaultProxy> </system.net>

    Some internet suggestions were to change the proxy server in code, but gave only a snippet, not sure where such code should go.

    I added proxy configurations to the web.config file per some suggestions - no help.

    This should not be this difficult...please help!

  2. Kenneth
    Kenneth avatar
    104 posts
    Member since:
    Apr 2014

    Posted 16 Dec 2016 in reply to Kenneth Link to this post

    RESOLVED

    edited C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Config\machine.cofig

    or on 64-bit C:\WINDOWS\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config

    added:

    <system.net>

    <defaultProxy useDefaultCredentials="true" enabled="true"> <proxy autoDetect="false" bypassonlocal="false" proxyaddress="http://127.0.0.1:8888" usesystemdefault="false" /> </defaultProxy>

    </system.net>

    to bottom of file (since there was no system,net node)

    and REBOOTED

    then opened fiddler

    then opened VS2010 and loaded project

    ran project..and it works!

  3. Plamen
    Plamen avatar
    2 posts
    Member since:
    Mar 2016

    Posted 07 Mar 2017 Link to this post

    Thank you for sharing this.

    Regards
Back to Top