Unable to use DragToTick method for RadSlider control

2 posts, 0 answers
  1. Maxim
    Maxim avatar
    1 posts
    Member since:
    Mar 2012

    Posted 23 Jul 2013 Link to this post


    I have RadSlider control with minimum and maximum values, and i'm trying to use DragToTick method but Test Studio returns me an error:

    ArtOfTest.Common.Exceptions.FindElementException: Element Not found!
    FindExpression used:
    [name 'Exact' HorizontalRangeEndThumb]

    Also, i tried to to execute the following coded steps against your demo page with RadSlider control but got the same error as for mine coded step.

    Site link: http://demos.telerik.com/silverlight/#Slider/Ticks

    Coded Steps:

    Telerik.WebAii.Controls.Xaml.RadSlider mySlider = Pages.TelerikSliderForSilverlight.SilverlightApp.Find.ByAutomationId<Telerik.WebAii.Controls.Xaml.RadSlider>("rangeSlider");

    //Thumb RangeMidle = severitySlider.Find.ByAutomationId<Thumb>("RangeMidleThumb");

    mySlider.DragToTick (ThumbName.EndThumb, 2);


    Exception thrown executing coded step: '[Performance_Categories_CodedStep8] : DragToTick - Telerik Demo'.
    ArtOfTest.Common.Exceptions.FindElementException: Element Not found!
    FindExpression used:
    [name 'Exact' HorizontalRangeEndThumb]

       at ArtOfTest.Common.WaitSync.CheckResult(WaitSync wait, String extraExceptionInfo, Object target)
       at ArtOfTest.Common.WaitSync.For[T](Predicate`1 predicate, T target, Boolean invertCondition, Int32 timeout, WaitResultType errorResultType)
       at ArtOfTest.WebAii.Silverlight.VisualWait.ForExistsInternal(Int32 timeout, Boolean invertCondition)
       at ArtOfTest.WebAii.Silverlight.VisualWait.ForVisible(Int32 timeout)
       at ArtOfTest.WebAii.Silverlight.VisualFind.ReturnOrThrow(FrameworkElement e, String throwMessage)
       at ArtOfTest.WebAii.Silverlight.VisualFind.ByName(String name)
       at Telerik.WebAii.Controls.Xaml.RadSlider.get_HorizontalRangeEndThumb()
       at Telerik.WebAii.Controls.Xaml.RadSlider.DragToTick(ThumbName thumbName, Int32 tickIndex)

    Could you help me please to fix that issue?

  2. Boyan Boev
    Boyan Boev avatar
    1072 posts

    Posted 24 Jul 2013 Link to this post

    Hello Maxim,

    I was able to reproduce the issue and I can confirm this is a bug. I have logged a bug report which you can track on our public portal.

    We appreciate your feedback, which we rely on to improve our product.

    Boyan Boev
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
Back to Top