Unable to record Application using fiddler2, however application working fine with fiddler4

4 posts, 0 answers
  1. Arvind Kumar
    Arvind Kumar avatar
    2 posts
    Member since:
    Jan 2016

    Posted 11 Jan 2016 Link to this post

    Hi All,
    I am trying to record an application using fiddler 2, during recording its not even loading login page.
    When checked in Fiddler logs and Inspector we see below message
    fiddler.network.https> HTTPS handshake to "Application" (for #2) failed. System.IO.IOException Received an unexpected EOF or 0 bytes from the transport stream.
    This is happening when "Decrypt HTTPS traffic" is checked, when unchecked, application is working fine.
    We tried by enabling/disabling other security options(SSL 3.0, TLS 1.0, 1.1, 1.2) but failed.

    Please note, we are able to record the same application using fiddler 4 but as per recommendations we have to use fiddler 2.

    Please help.

    Thanks in Advance,
  2. Vanya Pavlova
    Vanya Pavlova avatar
    2019 posts

    Posted 14 Jan 2016 Link to this post

    Hello Arvind,

    Fiddler2 should work fine on all major browsers. The first thing that comes to my mind is that something went wrong with the system configuration. Once you disable HTTPS decryption in Fiddler options, then click "Remove Interception Certificate". Afterwards, reenable decryption and click "Yes" on all prompts to trust the certificate. Then you should be able to load the site. 

    Please follow this procedure and let me know whether the issue still persists. 

    Vanya Pavlova
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Arvind Kumar
    Arvind Kumar avatar
    2 posts
    Member since:
    Jan 2016

    Posted 28 Jan 2016 Link to this post

    Thanks for the response Vanya.

    Tried that option, but issue still persisting. In addition to that, I removed all the DO_NOT_TRUST certificates by going to certmgr.msc with decrypt  HTTPS traffic disabled and tried recording again after enabling decrypt https traffic. But issue still persists

    The issue mostly appears to be  related to TLS handshake.

  4. EricLaw
    EricLaw avatar
    67 posts
    Member since:
    Oct 2012

    Posted 30 Jan 2016 in reply to Arvind Kumar Link to this post

    Fiddler 2 *only* supports SSL3.0 and TLS1.0 (this is a limitation of the .NET Framework).

    To enable TLS1.1 and TLS1.2 you must use .NET4 with Fiddler 4 on Windows 7 and later.

    Not sure what "as per recommendations" in your post means, but Fiddler2 should probably get retired soon.

Back to Top