This is a migrated thread and some comments may be shown as answers.

UI based process filtering for Edge doesn't work

1 Answer 54 Views
Windows
This is a migrated thread and some comments may be shown as answers.
Drew
Top achievements
Rank 1
Drew asked on 10 Sep 2015, 05:59 PM

If I grab the little target icon and drag it onto an Edge window/tab in the UI it always shows the same process id (the main MicrosoftEdge.exe process) and nothing is ever captured. Instead I have to manually go to the filtering tab, use the "Show only traffic from" drop down and figure out which MicrosoftEdgeCP.exe instance is the tab I'm interested in and filter it there.

I'm not sure what all you'll be able to do about this short of detecting it's MicrosoftEdge.exe ‚Äčand doing something more specific, but I thought I'd raise the issue to make sure you're aware of it.

 

1 Answer, 1 is accepted

Sort by
0
Eric Lawrence
Telerik team
answered on 10 Sep 2015, 08:37 PM
Hi, Drew--

Thanks for the note. The process filter works based on the owner of the window handle that displays the content.

If the Edge team is now drawing content out-of-process, you're right that the filter's behavior, while literally correct, is probably surprising to users.

Regards,
Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
Windows
Asked by
Drew
Top achievements
Rank 1
Answers by
Eric Lawrence
Telerik team
Share this question
or