TLS decryption

2 posts, 0 answers
  1. Mikkel
    Mikkel avatar
    1 posts
    Member since:
    Jan 2019

    Posted 23 Jan Link to this post

    Hi guys,

    I'm getting the following error:

    CONNECT :443 HTTP/1.1
    Host: :443
     
    A SSLv3-compatible ClientHello handshake was found. Fiddler extracted the parameters below.
     
    Version: 3.3 (TLS/1.2)
    Random: 0F 42 E4 A0 84 A5 05 4B 54 8C 2C 2B A1 F4 01 B8 9D 81 9A A8 74 FE 24 E8 46 15 19 68 3C BC 0E 01
    "Time": 16-07-2055 03:21:19
    SessionID: empty
    HTTP/1.1 200 Connection Established
    FiddlerGateway: Direct
    StartTime: 19:37:45.587
    Connection: close
     
    fiddler.network.https> HTTPS handshake to (for #1) failed. System.IO.IOException Received an unexpected EOF or 0 bytes from the transport stream.

     

    I have trusted the fiddler root certificate, imported it via mmc. Further more I have set fiddler to ignore certificate errors, and enabled the following protocols:

    <client>;ssl2;ssl3;tls1.0;tls1.1;tls1.2

    I'm using fiddler 4.5, but have also tried with version 2.

    I also tried searching for this issue, but no solution seemed to present itself. Usually adding tls1.2 worked for people, but not in my case :(

  2. Simeon
    Admin
    Simeon avatar
    231 posts

    Posted 29 Jan Link to this post

    Hello Mikkel,

    Could you, please, elaborate on what host you are trying to decrypt. I can see only the port number. Is it possible that it could use certificate pinning?

    Regards,
    Simeon
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top