This is a migrated thread and some comments may be shown as answers.
Testcases ignores executionTimeout in app.config
7 Answers 58 Views
This is a migrated thread and some comments may be shown as answers.
kwee
Top achievements
Rank 1
kwee asked on 08 May 2012, 01:15 AM
Hi,

I am using Telerik 2011.1.

When my tests run for more than 30 min, WebAii fails due to executionTimeout
exceeded. It seems to ignore the app.config setting for executionTimeout that I have
increased.

To reproduce the problem ( in reverse ), I used the
Samples/QuickStarts_VSTS_CS project and picked a passing testcase,
eg SimpleWin32UI.

Then I updated the app.config WebAii.Settings so that executionTimeout=0 ( or 1).
The testcase still runs and passes, and does not produce testcase timeout.
                                             
This shows that WebAii.Settings/executionTimeout is not being used.

Where should the executionTimeout value be set so that it can be effective?

Thanks,

7 Answers, 1 is accepted

Sort by
0
kwee
Top achievements
Rank 1
answered on 09 May 2012, 06:35 PM
Additional information

My test runs timeout like this:
 
     | Start Time:  5/7/2012 12:42:21 PM
     | Finish Time: 5/7/2012 1:12:21 PM
     | Test 'Create150Ships' exceeded execution timeout period.

It seems that my executionTimeout setting is ignored and the default 18000 ( 30 min ) value is
used.

There is another forum posting regarding the same issue, but no resolution was reported.

Reference : "Test exceeded execution timeout period"
   http://www.telerik.com/automated-testing-tools/community/forums/test-studio/general-discussions/test-exceeded-execution-timeout-period.aspx
0
kwee
Top achievements
Rank 1
answered on 10 May 2012, 04:28 AM
Additional information

I updated my TTF to 2012.1.411 and repeated the test.
The executionTimeout value is being read into the SettingsConfigSectionHandler,
but has no effect on the testcase. When the value is set to very low, eg 0, 1, the
testcase continues to run to completion.

Hopefully, I get an answer soon.

Thanks,
0
Cody
Telerik team
answered on 10 May 2012, 10:10 PM
Hello kwee,

I apologize for the confusion on the correct use of the executionTimeout parameter. It does not control the total amount of time the test may execute. It is the same thing as the ExecuteCommandTimeout setting documented here.

The setting you really need is the Visual Studio Test Timeouts contained in the Visual Studio .testsettings file (see attached screen shot).

Greetings,
Cody
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
kwee
Top achievements
Rank 1
answered on 11 May 2012, 12:45 AM
Great! I'll try it out soon. Thanks for the clarification.
0
Mostafa
Top achievements
Rank 2
answered on 27 Nov 2012, 11:03 AM
how can i create the Visual Studio .testsettings file, i can't find the file and i have the same Problem with the Timeout.

I run the test with mstest program through a test list,The first  test succeeds, and the second one has a timeout?

can u please help me???

regards
Mostafa
0
Plamen
Telerik team
answered on 27 Nov 2012, 12:20 PM
Hello Mostafa,

Please see this video on how to add the .testsettings file and where to find the Visual Studio Test Timeouts settings.

Let me know if you need further assistance on this.

Regards,
Plamen
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Mostafa
Top achievements
Rank 2
answered on 27 Nov 2012, 03:45 PM
Thanks for the clarification.
Asked by
kwee
Top achievements
Rank 1
Answers by
kwee
Top achievements
Rank 1
Cody
Telerik team
Mostafa
Top achievements
Rank 2
Plamen
Telerik team
Share this question
or