This is a migrated thread and some comments may be shown as answers.

Provide a place to enter the proxy details

8 Answers 771 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Telerik Admin
Top achievements
Rank 1
Telerik Admin asked on 26 Jun 2013, 07:43 AM
Hello everyone,

In connection with this UserVoice idea, we want to suggest a workaround.

Please override the “JustDecompile.exe.config”(located in the root folder of the JustDecompile.exe) using the shared content below. This way JustDecompile will be able to bypass the local proxy server, if any. Those configurations will tell JD to use the default proxy settings defined in the IE option panel.

<?xml version="1.0"?>
<configuration>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
  </startup>
  <runtime>
    <loadFromRemoteSources enabled="true"/>
  </runtime>
  <system.serviceModel>
    <bindings>
      <basicHttpBinding>
        <binding name="BasicHttpBinding_IUpdatesService" />
      </basicHttpBinding>
    </bindings>
    <client>
          binding="basicHttpBinding" bindingConfiguration="BasicHttpBinding_IUpdatesService"
          contract="Services.IUpdatesService" name="BasicHttpBinding_IUpdatesService" />
    </client>
  </system.serviceModel>
  <system.net>
    <defaultProxy enabled="true" useDefaultCredentials="true">
      <proxy autoDetect="True"/>
    </defaultProxy>
  </system.net>
</configuration>

Please let us know should you have any issues doing so.

Best,
The JustDecompile team

8 Answers, 1 is accepted

Sort by
0
Joerg
Top achievements
Rank 1
answered on 09 Dec 2013, 03:37 PM
Looking into the .config file as it is installed with the current version (2013.3.1029.1) the section seems to be there already, however it does not work. Usage of or authentication still seems to fail against the company proxy, however browsing via IE works perfectly fine.

The .config for version 2013.3.1029.1 looks like this:

<?xml version="1.0"?>
<configuration>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
  </startup>
  <runtime>
    <loadFromRemoteSources enabled="true"/>
  </runtime>
  <system.serviceModel>
    <bindings>
      <basicHttpBinding>
        <binding name="BasicHttpBinding_IUpdatesService" />
      </basicHttpBinding>
    </bindings>
    <client>
          binding="basicHttpBinding" bindingConfiguration="BasicHttpBinding_IUpdatesService"
          contract="Services.IUpdatesService" name="BasicHttpBinding_IUpdatesService" />
    </client>
  </system.serviceModel>
  <system.net>
    <defaultProxy enabled="true" useDefaultCredentials="true">
      <proxy autoDetect="True"/>
    </defaultProxy>
  </system.net>
</configuration>

Is there any other way to get this working?

Thanks,
-Jörg
0
Momchil
Telerik team
answered on 11 Dec 2013, 09:40 AM
Hi there,

Could you please tell us what operating system do you use?

Thanks.

Regards,
Momchil
Telerik
Tell us what you think about JustDecompile. Your opinion matters! You can use our forum, or our JustDecompile UserVoice website for feature requests.
0
Joerg
Top achievements
Rank 1
answered on 11 Dec 2013, 09:56 AM
Good morning Momchill,

it's a Windows 7 64bit (Enterprise Edt)  machine.

Best regards,
-Jörg
0
Momchil
Telerik team
answered on 14 Dec 2013, 08:20 AM
Hi there,

could please try overriding the .config file with:

<?xml version="1.0"?>
<configuration>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
  </startup>
  <runtime>
    <loadFromRemoteSources enabled="true"/>
  </runtime>
  <system.serviceModel>
    <bindings>
      <basicHttpBinding>
        <binding name="BasicHttpBinding_IUpdatesService" />
      </basicHttpBinding>
    </bindings>
    <client>
          binding="basicHttpBinding" bindingConfiguration="BasicHttpBinding_IUpdatesService"
          contract="Services.IUpdatesService" name="BasicHttpBinding_IUpdatesService" />
    </client>
  </system.serviceModel>
  <system.net>
    <defaultProxy enabled="true" useDefaultCredentials="true">
      <proxy usesystemdefault="true"/>
    </defaultProxy>
  </system.net>
</configuration>

The only difference is in the <proxy autoDetect="True"/>
 line, which is replaced by <proxy usesystemdefault="true"/>.

Thanks.

Regards,
Momchil
Telerik
Tell us what you think about JustDecompile. Your opinion matters! You can use our forum, or our JustDecompile UserVoice website for feature requests.
0
Holger Boskugel
Top achievements
Rank 2
answered on 23 Jun 2014, 08:18 AM
Hello,

I'm working in a environment of a large international company. There I had to remove the XML-Element "proxy" in configuration to get update working.

<?xml version="1.0"?>
<configuration>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
  </startup>
  <runtime>
    <loadFromRemoteSources enabled="true"/>
  </runtime>
  <system.serviceModel>
    <bindings>
      <basicHttpBinding>
        <binding name="BasicHttpBinding_IUpdatesService" />
      </basicHttpBinding>
    </bindings>
    <client>
          binding="basicHttpBinding" bindingConfiguration="BasicHttpBinding_IUpdatesService"
          contract="Services.IUpdatesService" name="BasicHttpBinding_IUpdatesService" />
    </client>
  </system.serviceModel>
  <system.net>
    <defaultProxy enabled="true" useDefaultCredentials="true"/>
  </system.net>
</configuration>


Regards

Holger
0
Adrian
Top achievements
Rank 1
answered on 03 Feb 2015, 04:57 PM
For me, I had to edit the config file to use an unauthenticated proxy, AND disable expect100Continue.
It would be nice if the update noticed the changes to the config file and left them in place! 
...
  <system.net>
      
    <defaultProxy enabled="true" >
      <proxy autoDetect="false" proxyaddress="http://xxxxxxxxx:9999" />
    </defaultProxy>
     
    <settings>
      <servicePointManager expect100Continue="false" />
    </settings>
  </system.net>
0
Alexander
Telerik team
answered on 05 Feb 2015, 11:35 AM
Hello Adrian,

Thank you for your feedback. We will add this bug to our backlog.

Please, update regularly and stay tuned.

Regards,
Alexander Dimitrov
Telerik
Martin
Top achievements
Rank 1
Iron
commented on 21 Jun 2021, 10:18 AM

Hi all,
I tried all the options I found on the forum. Unfortunately, nothing works from them and the program still behaves the same - the program still cannot connect and install plugins. The error message is in Czech windows:
"Cannot connect to JustDecompile server.
Please, check your internet connection.
Nelze vytvořit zabezpečený kanál pro režim SSL/TLS s autoritou justdecompile.telerik.com."
(Translation: Unable to create secure channel for SSL / TLS mode with justdecompile.telerik.com.)
It seems to me that there is a problem with the web certificate, but I am not able to recognize it.
Thanks for the answer and solution.
Regards
Martin
Nick Iliev
Telerik team
commented on 22 Jun 2021, 08:56 AM

The team is working on a solution to fix the inability to use 3rd-party plugins with JustDecompile. I will update this thread as soon as we have a stable one published live.
John
Top achievements
Rank 1
commented on 12 Nov 2021, 05:03 PM

Has there been any update on this from the Developers? We are running the latest version 19.1.118.0 and we are getting this error when trying to use Plugin Manager
0
master
Top achievements
Rank 1
Iron
answered on 14 Nov 2021, 10:55 AM
any news ? PLS help me to solve this issue 
Tags
General Discussions
Asked by
Telerik Admin
Top achievements
Rank 1
Answers by
Joerg
Top achievements
Rank 1
Momchil
Telerik team
Holger Boskugel
Top achievements
Rank 2
Adrian
Top achievements
Rank 1
Alexander
Telerik team
master
Top achievements
Rank 1
Iron
Share this question
or