Not Installing Design Files

Thread is closed for posting
2 posts, 0 answers
  1. Kyle
    Kyle avatar
    1 posts
    Member since:
    Jun 2014

    Posted 19 May 2015 Link to this post

    I'm currently running VS2013, and when I've tried to install Data Access Free Edition I am running into some problems. When I first tried to install Data Access, I had to manually add it into VS. Now that Data Access is added I have the Telerik Data Access on the menu bar, but none of the options from it work. When I try to click on one of the options there is a pop up saying either:


    • Invalid capability expression at position 29 in the expression "CPS Projects | Test | VisualC".
      Parameter name: capabilityExpression


    • Exception:  Unable to load the required template.


    I've tried re-installing a few times with no luck on getting Data Access to work. Any help would be appreciated. 

  2. Momchil
    Momchil avatar
    83 posts

    Posted 20 May 2015 Link to this post

    Hello Kyle,

    First of all, make sure that, and are available at "%ProgramFiles(x86)%\Telerik\Data Access\dsl2013\ItemTemplates\CSharp\Data\1033". Those files actually contain the needed templates. If they are not available, please uninstall and then install Telerik Data Access.

    If those files are available, please close all Visual Studio instances, start the Developer Command Prompt for VS2013 (a shortcut should be available in the start menu) and execute the following command:

    devenv /installvstemplates

    If this does not fix the issue and the templates are still not found, you will have to copy 
    "%ProgramFiles(x86)%\Telerik\Data Access\dsl2013\ItemTemplates\CSharp" folder and paste it into the
    "My Documents\Visual Studio 2013\Templates\ItemTemplates" folder and then restart the Visual Studio.

    Please let us know if you need further assistance.

    OpenAccess ORM is now Telerik Data Access. For more information on the new names, please, check out the Telerik Product Map.
Back to Top